trunk: fix for filters.svg

Bug #1248542 reported by v1nce on 2013-11-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
v1nce

Bug Description

There are buggy/unwanted/empty definition in filters.svg
Some crash inkscape

See attached file for fix.
Warning : I commented out some filters

v1nce (vincent-pennec) wrote :
su_v (suv-lp) wrote :

Please provide information for which Inkscape version (stable or trunk (revision)) this modified file is intended/based on.

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Incomplete
tags: added: filters-svg
v1nce (vincent-pennec) wrote :

Think it comes with 0.48 dev 12524 41 ubuntu 12.04.1

v1nce (vincent-pennec) wrote :

devel 12777 is affected too

su_v (suv-lp) on 2013-11-06
summary: - fix for filters.svg
+ trunk: fix for filters.svg
Changed in inkscape:
status: Incomplete → New
v1nce (vincent-pennec) wrote :

warning : this is not a clean fix, I just add comment around faulty filters (with reason why I think they're faulty)

v1nce (vincent-pennec) wrote :

The filter "Fill Background" crashes my inkscape so I think it deserves more than a wish list :)

su_v (suv-lp) wrote :

> so I think it deserves more than a wish list :)

Well, then you might not have mixed fixes for filters which trigger a crash into a diffuse report about 'buggy/unwanted/empty' filters. Separate _diffs_ for the different kinds of proposed changes would have made triage easier…

Someone will update the report status once all changes hidden in the attached file have been looked at, classified as 'crash' fix, or other change and tested. This might take time…

jazzynico (jazzynico) wrote :

It seems that some of the filters are a bit buggy indeed. Since it's going to take some time to be checked and fixed (it also needs to be ported to the trunk), I'm setting importance to Low for now. A different report (with higher priority) will be created if I can confirm the crashers.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
importance: Wishlist → Low
status: New → Triaged
v1nce (vincent-pennec) wrote :

I created a special bug report for the filter that crashes inkscape
1249390

jazzynico (jazzynico) wrote :

New report involving the feImages primitive (used in Fill Background and Fill Area): Bug #1249430 "feImage filter primitive crashes Inkscape when using an SVG file".
Could you please confirm it's the same issue you're experiencing? I've tested the two filters, and they only crash when using SVG images as source (it works correctly with bitmaps, and doesn't crash with an empty href).

jazzynico (jazzynico) wrote :

@ivan - I've subscribed you to the report because V1nce has spotted some unused filters, and I'm not sure if it was intentional or not. Would you be willing to take a look please?

There are some other errors related to in and in2 attributes linked to inexistent filters. If I remember correctly, invalid values are just discarded and the primitive uses the preceding primitive as default entry. I don't remember if the SVG specs accept that we just drop the invalid attribute. If not, I guess we should replace the invalid value with the reference of the preceding primitive manually.

jazzynico (jazzynico) on 2013-11-09
Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) on 2013-11-13
Changed in inkscape:
milestone: none → 0.49
jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 13024.
in and in2 attributes fixed, unused primitives and buggy filters removed. Almost all the work already done in your patch.

Thanks, v1nce!

Changed in inkscape:
assignee: jazzynico (jazzynico) → v1nce (vincent-pennec)
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers