Text toolbar spinboxes are not really useful with default units changed

Bug #1248120 reported by Vladimir Savic on 2013-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

Steps to reproduce:

With new document opened ->
Enter some text on canvas and go to "Spacing between letters (px)" spinbox (BTW, I think "px" is incorrect in trunk) and enter some arbitrary value there. All good! Small arrow icons beside entry-field work too.

Change Default units to mm using Document properties.
Enter new value in the same spinbox. It'll go crazy. Spinbox arrow for increasing numeric value will now make letter spacing smaller on every click.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 12782.

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.49
status: New → Triaged
tags: added: regression text ui
su_v (suv-lp) wrote :

I didn't take a closer look yet, but as discussed with vlada on irc, this seems to be related to
Bug #772057: Inconsistent handling of parent transforms or 'viewBox' attribute in text tool controls
<https://bugs.launchpad.net/inkscape/+bug/772057>

su_v (suv-lp) on 2014-03-26
tags: added: viewbox
ScislaC (scislac) wrote :

I can't reproduce this here with 13520 and the steps in the original report.

su_v (suv-lp) wrote :

Later regression wrt spinboxes on the text tool controls bar which might overshadow the issue reported here:
- Bug #1334702 “trunk: text tool spinboxes not behaving as expected (rev >= 13298)”
  <https://bugs.launchpad.net/inkscape/+bug/1334702>

su_v (suv-lp) wrote :

Affects text editing in trunk (rev >= 13641, updated templates) in new documents based on the default template (uses 'mm' as default units).

Changed in inkscape:
milestone: 0.91 → 0.92
Alvin Penner (apenner) wrote :

fix committed to rev 13937, please re-test, similar to Bug 772057

su_v (suv-lp) wrote :

@vlada - can you confirm this fixed in trunk rev >= 13937?

@~suv - I'd say that this one is through! Feel free to close it.

su_v (suv-lp) wrote :

Fixed with rev 13937 (for bug #772057).

Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
status: Triaged → Fix Committed
su_v (suv-lp) wrote :

Updating milestone (see bug #772057): trunk r13937 was backported to 0.91.x in r13749.

Changed in inkscape:
milestone: 0.92 → 0.91.1
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers