cannot de-select objects by clicking on the canvas (rev >= 12586)

Bug #1243408 reported by Ryan Lerch on 2013-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Martin Owens

Bug Description

Intermittently, when selecting multiple objects by rubber-banding, i cannot de-select these items by clicking on the canvas.

Clicking on another object, however does deselect the previously selected items.

see screencast for this issue in action. (note that i had to try multiple times to get this bug to present)

I am encountering this issue on Fedora 20 (GNOME 3.10) and Inkscape trunk r12712

Ryan Lerch (ryanlerch) wrote :
su_v (suv-lp) on 2013-10-22
tags: added: selection
Ryan Lerch (ryanlerch) on 2013-10-22
description: updated
su_v (suv-lp) wrote :

Not reproduced (based on the steps in the video) with r12712 on OS X 10.7.5 (tested with X11- and Quartz-based builds).

Ryan Lerch (ryanlerch) wrote :

I cannont re-create on Inkscape 0.48.4 r9939 on the same Fedora 20 system.

i tried about 50 times to re-create.

su_v (suv-lp) on 2013-10-22
tags: added: regression
LucaDC (dicappello) wrote :

I'm experiencing this bug under Windows XP too.
I couldn't understand exactly what triggers it, but it's not only rubber-selecting: sometimes I start working on an object (e.g. moving its nodes), then when I'm finished I can't deselect it but with clicking on another object.
And sometimes I experience the opposite: just after modifying an object and deselecting it I can't reselect it anymore: the solution that usually works for me is to zoom in and out after selecting some other objects.

jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf (Debian stable), Inkscape trunk revision 12715.
Not reproduced with 0.48.3.1.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) on 2013-10-23
Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

Steps to trigger the regression:

1) launch trunk (default prefs, default new doc)
2) draw a couple of objects
3) drag a selection frame around the objects
4) drag a small selection frame over an empty canvas area

Expected result:
With current stable and trunk rev <= 12585, the current selection is deselected

Actual result:
With trunk rev >= 12586, the current selection is not deselected, and can no longer be deselected with a single click on an empty canvas area.

I suspect that with an external mouse, it may happen (often unnoticed) that the click on an empty canvas area to deselect the current selection is actually a 'mini-drag' instead of a real click, which triggers this changed behavior.

AFAICT this regression was introduced with
Revision 12586: Make sure selection->setList checks for dupes by routing to selection->addList.
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12586>

Changed in inkscape:
importance: Low → Medium
status: Confirmed → Triaged
summary: - Intermittantly cannot de-select objects by clicking on the canvas
+ Intermittantly cannot de-select objects by clicking on the canvas (rev
+ >= 12586)

Confirmed that suv's steps to reproduce work. Dragging a small selection frame causes this one.

summary: - Intermittantly cannot de-select objects by clicking on the canvas (rev
- >= 12586)
+ cannot de-select objects by clicking on the canvas (rev >= 12586)
Martin Owens (doctormo) wrote :

Fixed in r12755. The selection /was/ cleared, but the signal was not emitted if the list was empty.

I also removed the warnings when compiling selection.cpp and collapsed that code in that revision too. Ignore for this bug.

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Triaged → Fix Committed
su_v (suv-lp) on 2013-10-31
Changed in inkscape:
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers