trunk: symbol preview no longer updates after modifing symbol of current document

Bug #1239779 reported by su_v on 2013-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Martin Owens

Bug Description

Steps to reproduce:
1) launch current trunk (default prefs, default new document)
2) open 'Object > Symbols'
3) select the 'Symbol Signs' symbol set
4) grab the first symbol and drop it onto canvas
5) switch to the 'Current document' symbol set
6) select the symbol in the dialog and click on the button "Remove Symbol from the current document" to edit some of its features on-canvas
7) zoom in on the group in the upper left page corner
8) switch to the node tool and select the rectangle (white stroke, unset fill) stacked at the bottom of the group
9) change the color to red
10) optionally node-edit some of the paths on top of that rectangle
11) deselect everything, reselect the parent group and click on "Add Symbol from the current document" in the symbols dialog

Expected result:
The preview of the symbol in the dialog is updated to reflect the changes just done to it (change background color, etc.).

Actual result:
The symbol preview stays unchanged (previews at different sizes though show the updated image).

Confirmed with r12687 on OS X 10.7.5

Based on tests with archived builds:
- not reproduced with rev <= 12511,
- reproduced with rev >= 12517,
the lack of updating the preview seems to have been introduced with one of the changes in rev 12512 - 12517:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/12517>

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 12688.

Changed in inkscape:
status: New → Triaged
su_v (suv-lp) on 2013-10-15
Changed in inkscape:
importance: Undecided → Low
Martin Owens (doctormo) wrote :

I think the right way to do this is to:

a) Remove the cache when we do revertSymbol, right now that calls out to a verb so the key needs to be generated from whatever information we can gleam.
b) Put in a signal so when the symbol changes, we can update the cache and the icon.

Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
Martin Owens (doctormo) wrote :

I've fixed the issue in r12924, I had a play around with different ways to get caching installed correctly. But since we're already caching the pixbuf in the glist, I've removed the extra caching step.

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers