trunk: Opening a new document via Templates dialog produces critical warning (rev >= 12532)

Bug #1239419 reported by su_v on 2013-10-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Markus Engel

Bug Description

Steps to reproduce:
1) launch current trunk (default prefs, default new doc, locale: en_US.UTF-8)
2) open 'File > New > Templates…'
3) select a template, e.g. 'Desktop 640x480', and click on 'Create from template'

Console messages:

** (inkscape:76234): WARNING **: TypeNotRegistered exception: inkscape:_templateinfo

** (inkscape:76234): CRITICAL **: virtual void SPObject::remove_child(Inkscape::XML::Node*): assertion 'ochild != NULL || !strcmp("comment", child->name())' failed

Reproduced with r12682 on OS X 10.7.5

Based on tests with archived builds:
- not reproduced with rev <= 12531
- reproduced with rev >= 12532
this console message originates in the changes from the merged C++ification branch in rev 12532:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/12532>

su_v (suv-lp) wrote :

@Markus - may you can take a closer look?

Markus Engel (engelmarkus) wrote :

Fixed in r12686.

Changed in inkscape:
assignee: nobody → Markus Engel (engelmarkus)
status: New → Fix Released
su_v (suv-lp) on 2013-10-13
Changed in inkscape:
milestone: 0.49 → none
Alvin Penner (apenner) wrote :

re-opening on Windows XP, Inkscape rev 12991, due to following messages:

Steps to reproduce:
 1) launch current trunk (default prefs, default new doc)
 2) open 'File > New > Templates…'
 3) select a template, e.g. 'Desktop 640x480', and click on 'Create from template'

template is created, but get messages. The rdf messages are probably irrelevant here, but the rest look similar to above:

...................................................................................

** (inkscape.exe:3272): WARNING **: unknown type: rdf:RDF

(inkscape.exe:3272): glibmm-CRITICAL **:
unhandled exception (type Glib::Error) in signal handler:
domain: gdk-pixbuf-error-quark
code : 3
what : Couldn't recognize the image file format for file 'C:\InkscapeBZR\inkscape\share\templates\desktop_640x480.svg'

** (inkscape.exe:3272): WARNING **: unknown type: rdf:RDF

** (inkscape.exe:3272): WARNING **: unknown type: inkscape:_templateinfo

su_v (suv-lp) wrote :

Note: the gdk-pixbuf-error-quark is tracked in bug #1271938.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers