orientation of arc segment is inverted upon saving and viewing in other software.

Bug #1237734 reported by Alvin Penner on 2013-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Markus Engel

Bug Description

- running Windows XP, Inkscape r12676
- draw ellipse, set start = 90, end = 0
- note that open quadrant is at bottom right, as it previously was
- save as quad.svg, attached
- reload into Inkscape and note that image is the same as before.
- load into IE8, or Gimp, and the image is inverted, closed quadrant is at bottom right, the rest is open.

Alvin Penner (apenner) wrote :
Alvin Penner (apenner) wrote :

the flags in the arc element are being set differently than before. In current trunk the arc looks like:

d="m 261.42856,249.50504 a 115.71429,40 0 0 0 115.71429,-40 l -115.71429,0 z"

where the three direction determining flags are set at (0, 0, 0). In Inkscape 0.48.4 these flags would have been set at (0, 1, 1)

su_v (suv-lp) wrote :

Reproduced with r12676 on OS X 10.7.5.

The test with archived builds shows:
- nor reproduced with rev <= 12627
- reproduced with rev >= 12629.
this change seems to have been introduced in
- Revision 12629: Further changes to SPEllipse.
  <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12629>

tags: added: regression shape-editing svg
Changed in inkscape:
assignee: nobody → Markus Engel (engelmarkus)
importance: Undecided → Medium
milestone: none → 0.49
status: New → Confirmed
Markus Engel (engelmarkus) wrote :

Could you please try the second patch here: bug #1235504
This should fix it.

Changed in inkscape:
status: Confirmed → In Progress
Alvin Penner (apenner) wrote :

sorry about that, I think I had previously applied only a portion of the patch because I was only interested in bbox.

anyways, yes, that works perfectly, thanks for the fix!

Markus Engel (engelmarkus) wrote :

Fixed in r12677.

Changed in inkscape:
status: In Progress → Fix Released
su_v (suv-lp) on 2013-10-10
Changed in inkscape:
milestone: 0.49 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments