trunk: node-tool/canvas loses focus when using <TAB> to cycle through nodes (rev >= 12532)

Bug #1237667 reported by su_v on 2013-10-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Markus Engel

Bug Description

Steps to reproduce:
1) Launch current trunk (default prefs, default new doc)
2) Draw e.g. a star
3) Convert to Path
4) Switch to the node tool ('N')
5) use <TAB> to cycle through the nodes of the current selected path

Expected result:
First <TAB> selects the start node, each <TAB> selects the next node in path direction.

Actual result:
The first <TAB> selects the start node, but then the focus is moved off-canvas, and the next <TAB> will affect whatever widget now has the focus (may be a docked dialog, or widgets in the status bar, or …). Pressing <TAB> with a node already selected selects the next node and then the focus is moved off-canvas. It is no longer possible to cycle though all nodes with the keyboard.

Confirmed with Inkscape 0.48+devel r12673 on OS X 10.7.5, and on Ubuntu 13.04 (ScislaC, local build).

Based on tests with archived builds (on OS X 10.7.5):
- not reproduced with rev <= 12531,
- reproduced with rev >= 12532,
this changed behavior seems to be a side-effect of the merge of the C++-ification branch in revision 12532:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12532>

su_v (suv-lp) wrote :

@Markus - maybe you could take a closer look at this one, too (if time permits)?

description: updated
su_v (suv-lp) wrote :

Same happens with 'Shift+TAB' to cycle through nodes in reverse order.

Markus Engel (engelmarkus) wrote :

Of course I can ;) . Fixed in r12675.

Changed in inkscape:
assignee: nobody → Markus Engel (engelmarkus)
status: New → Fix Released
su_v (suv-lp) wrote :

Thx :)

Changed in inkscape:
milestone: 0.49 → none
T_W (walshtc) on 2013-10-09
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers