trunk: add full keyboard navigation support for new templates dialog

Bug #1236282 reported by su_v on 2013-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
jazzynico

Bug Description

<quote>
The new dialog currently forces the use of the mouse, even to trigger a button (or presumed default action). It would be great if the new dialog also supported features like
1) double-click on list item creates new document based on template (see for example the dialog to select path effects)
2) basic keyboard-based navigation (like in all other parts of the GUI) Currently, activation of a focused GUI widget with <Space> or <Return> does not work for both buttons in the new dialog: the buttons are visually pressed, but nothing else happens (no action triggered).
</quote>
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/41162/focus=41230>

Tested with trunk on Ubuntu 12.04 (PPA), 12.10 (local build), 13.04 (PPA) and on OS X 10.7.5.

su_v (suv-lp) on 2013-10-07
tags: added: templates
jazzynico (jazzynico) on 2013-10-08
Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) on 2013-12-06
Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) on 2013-12-09
Changed in inkscape:
assignee: Slagvi (slagvi) → jazzynico (jazzynico)
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

New patch attached.
It adds template creation when double-clicking (or pressing <enter> or <space>) on the list.
Note that creating a template that way doesn't close the NFT dialog (you have to click on the close icon or press <esc>).
Tell me if you find it more convenient to quit the dialog when a template is created (if not, the button behavior can easily be changed accordingly for consistency).

jazzynico (jazzynico) wrote :

Patch committed revision 12862 so that more users can test.
Leaving the report open for now.

Martin Owens (doctormo) wrote :

Further tests show that the dialog is working with the keyboard and works completely. I went through each widget and made sure I could go from fresh open to a templated document just with the keyboard.

I'm happy to close the bug for you jazzynico :-)

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

On 2013-12-10 09:35 +0100, jazzynico wrote:
> Note that creating a template that way doesn't close the NFT dialog
> (you have to click on the close icon or press <esc>). Tell me if you
> find it more convenient to quit the dialog when a template is created
> (if not, the button behavior can easily be changed accordingly for
> consistency).

Personally, I would expect the dialog to close if I double-click on a list entry - same behavior as with the 'Move to layer...' and path effect selection dialog (both for quicker navigation and consistency). @JazzyNico - did you have specific reasons to keep the dialog open? I can file a separate wishlist report now that this one was closed.

jazzynico (jazzynico) wrote :

~suv> did you have specific reasons to keep the dialog open?

Yes, I was waiting for a comment on #2, that you just gave me in #5 ;)

Note that the navigation patch was quite obvious, but due to the dialog design, closing when double clicking on the list is not (at least for me). I'm going to take a second look.

jazzynico (jazzynico) wrote :

Additional patch that closes the dialog when selecting a template.

@Martin, could you please review the code? I'm not a fluent C++ writer, and I'm not sure I made the best choice here.

jazzynico (jazzynico) wrote :

Additional patch committed revision 12934.

jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers