trunk: measure tool always starts to measure at (0,0) (desktop coords) (rev >= 12602)

Bug #1232494 reported by su_v on 2013-09-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Markus Engel

Bug Description

Steps to reproduce:
1) launch inkscape (default prefs, default new document)
2) switch to the measure tool ('M')
3) click and start dragging anywhere on the canvas

Expected result:
The reference point for the measured distance/angle is exactly where the drag started.

Actual result:
The reference point of the measured distance/angle is always (0,0), the lower left corner of the page.

Based on tests [*] with archived builds:
- not reproduced with r12601 and earlier revisions
- reproduced with r12602 and later revisions,
this regression was introduced in
Revision 12602: Adjusted code style of SPEllipse.
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12602>

[*] All tests done on OS X 10.7.5.

su_v (suv-lp) wrote :

Also broken: tapping 'Shift' used to reset the baseline for the measured angle to the current position.

Originally implemented in
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11459>

Changed in inkscape:
importance: Undecided → Medium
Markus Engel (engelmarkus) wrote :

Sorry for breaking this, I tested that but it seems I didn't notice it. Global variables... :(

Changed in inkscape:
assignee: nobody → Markus Engel (engelmarkus)
status: New → Fix Released
Markus Engel (engelmarkus) wrote :

Fixed in r12613.

su_v (suv-lp) on 2013-09-28
Changed in inkscape:
milestone: 0.49 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers