Tweak tool: undoing sculpt changes color (in specific file)

Bug #1225481 reported by Antoine Youssef Kamel on 2013-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Windows 7 64 bits Home Premium SP1
Inkscape 0.48.4

In the annexed file, when I use the tweak tool in the text part and undo it (ctrl+z), the color of the text is changed.

su_v (suv-lp) wrote :

The first time a text object is edited with the Tweak tool, it is transparently converted to path i.e. to a group, containing a path for each letter.
When undoing such a first tweak edit of the (filtered) text object, the group is converted back to the text, still having the original filter applied.

Results:
- With current stable 0.48.4, the change of color occurs because the filter effect is not rendered at all, right after the undo.
- With current trunk (r12517), the text object disappears completely until a full redraw is forced (e.g. hide/show current layer).

AFAIU this is the same underlying issue as already tracked in earlier reports:
- Bug #930593 “Grouping/ungrouping of filtered objects (groups|texts|clones) makes them disappear temporarily”
  <https://bugs.launchpad.net/inkscape/+bug/930593>
- Bug #304407 “After ungrouping or decoupling a clone blur is no longer shown but style attribute still present.”
  <https://bugs.launchpad.net/inkscape/+bug/304407> (see steps in comment #3)
- Bug #243729 “Grouping filtered text objects looses rendering of filter effects”
  <https://bugs.launchpad.net/inkscape/+bug/243729> (see comment #8)

tags: added: filters-svg groups text
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Testing with more recent development builds:
- reproduced with r12526
- no longer reproduced with r12528 and latest r12577.

--> the fix for bug #243729 and bug #930593 in revision 12528 also solved the issue reported here.

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers