Incorrect node count after "Stroke to Path"

Bug #1212141 reported by rickmastfan67 on 2013-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Inkscape 0.48.4 r9939
Windows 7 x64

Steps to reproduce:
1. Open attached file (before).
2. Select the green "dot".
3. Path > Stroke to Path
4. Notice in the status bar at the bottom, it says the item now has "5 nodes".
5. Select the "Edit paths" tool (F2).
6. Select any node.

What happens:
The status bar says that "1 of 7 nodes selected."

What should happen:
Outside the "Edit paths" mode, the correct number of nodes in the item should be listed of 7 instead of 5.

I've attached both a "before" and "after" file.

rickmastfan67 (rickmastfan67) wrote :
rickmastfan67 (rickmastfan67) wrote :
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 12475.

tags: added: node-editing ui
Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
jazzynico (jazzynico) wrote :

Not reproduced on Xubuntu 15.04 with Inkscape 0.91 and trunk rev. 14309 (same count -4 nodes- with the selection and node tools).
Could you please confirm it's also fixed for you?

rickmastfan67 (rickmastfan67) wrote :

Looks like it is indeed fixed in 0.91.

jazzynico (jazzynico) on 2015-08-19
Changed in inkscape:
milestone: none → 0.91
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments