GTK3 Palettes that dont require a scroll bar bounce

Bug #1201545 reported by Ryan Lerch on 2013-07-15
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Liam P. White

Bug Description

On the experimental GTK3 build, if the color palette at the bottom of the screen is small engough (i.e. not enough colors) to not need a scrollbar, the palette resizes from the half-hieght to the full-height whenever the mouse is moved.

Attached is a screencast of the issue.

Ryan Lerch (ryanlerch) wrote :
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48+devel r12419 on OS X 10.7.5 with
- GTK+ 3.8.2, built-.in stock theme, (X11, Quartz backend)
- GTK+ 3.6.4, Adwaita (gnome-themes-standard 3.6.3), built-in stock theme, (Quartz backend)
- GTK+ 3.4.4, Adwaita (gnome-themes-standard 3.4.2), built-in stock theme, (X11 backend)

Reproduced with Inkscape 0.48+devel r 12419 on OS X 10.7.5 with
- GTK+ 3.8.2, Adwaita theme (gnome-themes-standard 3.8.1), (X11, Quartz backend)

Conflict with latest Adwaita theme engine for Gnome 3.8?

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: ui
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14842 on OS X 10.7.5 with
- GTK+ 3.18.8, built-in Adwaita theme (X11 backend)
- GTK+ 3.20.3, built-in Adwaita theme (Quartz backend)
with short palettes like 'Tango', but only if Inkscape was launched with
$ GTK_OVERLAY_SCROLLING=0 inkscape
to disable the (now gtk-native) overlay scrollbars.

If GTK+'s overlay scrollbars are enabled (default since >= 3.16 IIRC), there's no flickering in the palette (but larger palettes which are scrollable get overlayed with the scrollbar on hover and thus not clickable to assign a color -> separate issue).

Olof Bjarnason (objarni) wrote :

Nice research!

I tested using virtual machine produced by inkup - https://github.com/objarni/inkup i.e. Lubuntu 14.04 64-git.

Further testing reveal that the jumping only happens when moving mouse over color box' borders, or canvas. Moving over menus, rulers or toolbars leaves the palette inanimate.

Olof Bjarnason (objarni) wrote :

I'm not able to reproduce this anymore on r14870.

However, the palette seems to have the old "high hight" temporarily intermittently when switching between palettes or changing their style (width, height ...). Of course not ideal but not a show-stopper anymore, just a minor annoyance.

Tavmjong Bah (tavmjong-free) wrote :

I don't see why r14870 should have fixed this.

I disabled overlayed scrollbars for swatches in r14781. Overlayed scrollbars were introduced in Gtk 3.16.

What a pain to trace through the layers of objects to find out where to make this fix.

I didn't see the behavior described by this bug either before or after this code check-in. What I did notice is that selecting the "Wrap" option doubles the height of the swatches without doing any wrapping (in a Gtk3 build).

Olof Bjarnason (objarni) wrote :

#6 did you try reproduction steps from https://bugs.launchpad.net/inkscape/+bug/1569943 ?

Mc (mc...) wrote :

Committed a fix by LiamW to r15158

Changed in inkscape:
assignee: nobody → Liam P. White (liampwhite)
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2016-10-10
Changed in inkscape:
milestone: none → 0.93
Max Gaukler (mgmax) on 2020-05-09
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers