Can't build Inkscape on Windows

Bug #1198501 reported by Degot on 2013-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Martin Owens

Bug Description

Hello,
 I've checked out code from latest trunk (r12407) .
 I'm not able to compile it on Windows (OS : Win7, Building as it is written in Wiki "Compiling Inkscape on Windows"). Error messages attached.

 Problem is in seltrans-handles.h line 36... instead of "uint" it should be "guint".

Degot (vladimirdegtiar) wrote :
su_v (suv-lp) on 2013-07-06
tags: added: build win32
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

That particular line of code was added in r12401:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12401#src/seltrans-handles.h>

@Martin - any comments on the proposed fix for Windows builds?

Martin Owens (doctormo) wrote :

It's a sensible fix, so I've put it in. Please report back if it works now on Windows.

jazzynico (jazzynico) wrote :

Bug and fix confirmed on Windows XP. Replacing uint with guint fixes the issue and Inkscape compiles as expected.

Changed in inkscape:
status: New → In Progress
su_v (suv-lp) wrote :

Martin Owens wrote 19 hours ago:
> It's a sensible fix, so I've put it in. Please report back if it works now on Windows.

@Martin - AFAICT rev. 12408 (if you refer to that latest commit of yours) seems to contain unrelated changes - safe to revert for now, and instead commit the actual fix?

Martin Owens (doctormo) wrote :

How embarrassing, r12409 to fix that.

su_v (suv-lp) on 2013-07-09
Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: In Progress → Fix Released
huhu (23522293-a) wrote :

There is an error:

Make error line 448: LINK problem: build\obj\inkres.o: file not recognized: File
 format not recognized
collect2: ld returned 1 exit status.

How should i do?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers