cannot cancel (huge) export, inkscape hangs while processing

Bug #1195929 reported by insaner on 2013-06-28
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Patrick Storz

Bug Description

i was trying to export a simple file (4 layers of text) in a roughly 600x500px image.. so I select the filename and click on export and notice my processor fan goes nuts and its taking a long time (ie, it wasnt immediate) for some reason, the dpi had been set to 1440, and the export was creating 10000x7000 png..

so I tried to cancel, but it would not respond. that means that inkscape hung while it generated this huge file.

the bug is that pressing the cancel button doesn't work.

jazzynico (jazzynico) on 2013-10-08
tags: added: exporting
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 12670.
Inkscape always tries to finish its PNG export, no matter if you click on Cancel or not.

Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
tags: added: bitmap
Pander (pander) wrote :

This is still an issue for 0.91-3ubuntu1

Same here on 0.91 r13725 in Ubuntu 15.04.

Magnes (magnesus2) wrote :

I don't know why I was asked for more information - just load any image, set DPI to 400000 and click export. Now try to cancel the export while watching your harddrive burn. ;)

Changed in inkscape:
status: Triaged → Confirmed
Magnes (magnesus2) wrote :

Wait, this bug is 2 years old? Why wasn't this fixed already? Inkscape made many improvements over the years, hard to believe this wasn't noticed and fixed. Anyone reading this reports anyway?

su_v (suv-lp) on 2015-12-09
Changed in inkscape:
status: Confirmed → Triaged

Same problem here.
Version Inkscape 0.91pre4 r13712 (on win 7/64)

I did an export for the second time.
For whatever reason the settings changed to custom and had a 400k x 200k resolution.
As I recognized that, I tried to cancel, with no expected effect.
An effect was that I recognised that the cancel-button was recognised as the windows came in front after some time, but no cancel of the operation.
CPU was an 100% for one CPU (25% on 4 proc machine) all the time. some IO.

Needed to shoot-down task, and redo all changes done before (who the hell does a save before ;-) )

Jim Oliver (jim88888) wrote :

Any update on this one? It's now 4 years old.

Вня Седов (crtnr) wrote :

Still an issue.

Diego Loiola (alface8) wrote :

This problem happens to me too.

Inkscape 0.92.2 - Windows 10

Vladimir Nikšić (vniksic-9) wrote :

This is still an issue. 0.92.1 - Ubuntu 17.04

Patrick Storz (ede123) wrote :

Fix committed to 0.92.x branch in
https://gitlab.com/inkscape/inkscape/commit/8858b2a850b060ae50611c0fab8517ff97e2a332
and master in
https://gitlab.com/inkscape/inkscape/commit/b071ae75610f98247e2efb602884e240aeeb80d8

Canceling bitmap export should be working fine now (there can still be a small delay as Inkscape splits the image into horizontal stripes and the current stripe always needs to be finished).

Changed in inkscape:
status: Triaged → Fix Committed
assignee: nobody → Eduard Braun (eduard-braun2)
milestone: none → 0.92.3
Bryce Harrington (bryce) on 2018-05-12
Changed in inkscape:
status: Fix Committed → Fix Released
Web Catt (webcatt) wrote :

Hmmm...Ok, so it's April 5th 2000 Nineteen and I'm pretty sure I'm using Inkscape V. 0.92.3 though I cant check because the program is locked up trying to Export the largest file I've ever Seen in my over 20 years on the internet!!! I mean, a Fix??? NO! There has been no fix, this is like the second or third time this has happened to me, but one time I could have "sworn" I was able to multi-click that Cancel button and got it to close, I'm probably only imagining it, but the last times the file was no where as big as it is now (see attachment - if this site even let my attachment come through - sorry, I'm distrusting software right now in my life) So yea, this has got to be the STUPIDEST bug in software history to have. I mean, why did the U.I. guy even create the Cancel Button? I mean why? And what "really" sucks for "me" right now...is I had gotton so good into my design (i am aware this is of my own fault here) that I had not clicked the save button One Single Time. So I "cant" just End Task the software, or I have lost over and hour and a half of work (boy an hour goes by fast when you're designing, sheeesh!) So I'm like screwed right now, I "HAVE" to wait this dumb A$$ crap out! Come on inkscape people??? I mean, you "created Inkscape" surely you can fix any "bugs" that it gets....Right?

Patrick Storz (ede123) wrote :

Well, as you seem to have some (waiting) time at you hands, maybe re-check you Inkscape version...

If you're really using 0.92.3 or later and the cancel button actually does *not* cancel the export for you, you're elcome to report a new issue (with a sample file and precise steps on how to reproduce) at https://inkscape.org/report.

Web Catt (webcatt) wrote :

Ha haaaaaa! Good one, I definitely thought I was screw Pat, but I apologize for my out burst. I'm a frank and straight up guy and I'm honest enough to say when my Shhhhhh Stanks. So to Pat and to anyone else who read my post or who may read it in the future, Version 92.3 will allow you to CANCEL, heck, it' actually even Exports Smoother and Faster to where I didn't even have to cancel because it exported so fast. I created a 17 object, 11286px x 5750px project just to test 92.3 and like I said, I really didn't even have to cancel it, I just cancelled it to Test that it would cancel and it did. Thing is, the export was moving so swift, you wouldnt have to cancel. BUT NOW...lol, let me tell yall how I actually got "OUT" of my first dilemma previously and pissed-offedly spoken of (lol). So what I did was turn on my desktop computer which I have right beside my laptop (the one that had inkscape exporting) And I thought to myself, let me remove my 2TB drive and just start working from my desktop while that thing exports, well turns out, that since I was saving that export "To That External Drive" when I unplugged the drive, that terminated the export for me. So any of you still using V. 92.1 like I actually was (that's why I apologized to @Patrick Storz) think about where you are exporting "to" if it's an external drive or usb, see if unpluggin it will work. If it's your main drive, you may try going into your hardware setting and temporarily disabling the drive, "just to kill" the export, then turn it back on. I hope that helps someone who may be as pissed as I was, caw as my previous post will show, I was livid and now I know better. Im a realist, I go off of the facts I have at the moment and I react accordingly, but if I find those facts to change, I'm man enough to admit I was wrong. 92.3 "Does Cancel" - The End! Written, Produced and Directed by a formerly disgruntled customer lol Hey hope this helps someone ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments