rearranging Layers may shift object location

Bug #1194091 reported by Anonymous on 2013-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

while rearranging several layers in a large complex drawing, I found, that in my case the objects on the moved layers where geometrically shifted. I deleted most of the original drawing, so only the small file still containing the bug remains.
Please see attached file: Layer_rearrange_bug.svg

It only contains two layers on the most top level, called Layer_A and Layer_B, while Layer a has two sub layers.
Except of Layer_B, all other Layers doesn't contain any drawing item.

If you now drag and drop in the Layer Window the Layer_B in-between the sub layers of Layer_A, than the red square will be shifted.

InkScape Version 0.48+devel_r11717_lp988601
Win7, 64 bit, 8 GB RAM

Happens with inkscape_r12378-201306161123 too.

Anonymous (susi-8888) wrote :
Anonymous (susi-8888) on 2013-06-24
summary: - rearanging Layers may shift object location
+ rearranging Layers may shift object location
Anonymous (susi-8888) on 2013-06-24
description: updated
Martin Owens (doctormo) wrote :

The bug is confirmed on trunk branch.

Moving Layer_B to Layer_A or it's sub-layers causes the transformation because Layer_A has this translate:

transform="translate(106.299209595,46.0631670789)"

It should probably apply the reverse offset somehow, making sure to adjust for the transformations of any parent layers it's being moved from too.

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2013-06-24
Changed in inkscape:
importance: Undecided → Medium
tags: added: transformations
Mc (mc...) wrote :

fix committed to r 14142

Changed in inkscape:
assignee: nobody → Mc (mc...)
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-05-11
Changed in inkscape:
milestone: none → 0.92
su_v (suv-lp) wrote :

@Mc - with Inkscape 0.91+devel rev >= 14142, working with 3dboxes triggers these kinds of warnings repeatedly (also mentioned in bug #1478137):

** (inkscape:74243): CRITICAL **: virtual void Inkscape::XML::SimpleNode::changeOrder(Inkscape::XML::Node *, Inkscape::XML::Node *): assertion 'child != ref' failed

Any chance you could take a quick look at how they relate to the changes committed to fix this report, and whether they need to (or could be) addressed?

Mc (mc...) wrote :

Found it, fixed in r14268

Sorry for the inconvenience

su_v (suv-lp) wrote :

Related follow-up commit:
   revno: 14538
   committer: Marc Jeanmougin
   timestamp: Sat 2015-12-19 01:13:37 +0100
   message:
     fixes layer movement when there is a document scaling factor
   modified:
     src/ui/dialog/layers.cpp

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers