Use elements removed when symbol is turned into a group

Bug #1192023 reported by Martin Owens on 2013-06-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Martin Owens

Bug Description

When moving symbols from defs->symbol to layer->group all linked use elements are emptied as they do not track correctly and do not point to the new group element.

Martin Owens (doctormo) on 2013-06-18
Changed in inkscape:
status: New → Confirmed
assignee: nobody → Martin Owens (doctormo)
su_v (suv-lp) on 2013-07-05
Changed in inkscape:
milestone: none → 0.49
importance: Undecided → Medium
su_v (suv-lp) wrote :

See also:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/40635/focus=40658>

Raising bug importance to 'High' since this regression (not present in Tav's original implementation) can cause data loss (think of editing a large map, with many instances of map symbols, and the need to edit a detail in one of the symbol definitions (e.g. a fill color) - oops: all inserted instances of the same symbol are gone -> the user has to reinsert them again (if he recalls their exact positions at all), or to undo and to adjust to the old unedited symbols on the map).

Changed in inkscape:
importance: Medium → High
status: Confirmed → Triaged
tags: added: regression
Martin Owens (doctormo) wrote :

Fixed in r12899. This fix involves switching out the symbol's id when transferring ownership to the new group.

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers