On startup, main window is very large

Bug #1190828 reported by Rena Kunisaki on 2013-06-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Patrick Storz
0.92.x
Wishlist
Patrick Storz

Bug Description

Every time I start Inkscape, the main window starts out very large (3644x1594 pixels) and partially off-screen, and I have to drag it back onto the screen and shrink it down to a reasonable size. "Remember and use last window's geometry" is checked in preferences, and all tool windows reappear in the same position and size each time, but every startup the main window is back to this huge size and position off-screen.

I'm using nightly trunk builds (Lubuntu 12.10 on AMD64); this has been happening for a couple weeks now.

su_v (suv-lp) wrote :

Possibly related to recent changes to address the complaints filed in
- Bug #830663 “default window size is too small”
  <https://bugs.launchpad.net/inkscape/+bug/830663>

Could you test whether changing the value for the new preference 'Default Window size' makes a difference (Small|Large|Maximized)? It might also be worthwhile to first make a backup copy of the preferences file (~/.config/inkscape/preferences.xml), to allow to track (diff) changes between different sessions wrt to remembered size and positions.

Which WM are you using?

tags: added: regression ui
Rena Kunisaki (i-am-inuyasha) wrote :

When default window size is set to Small or Maximized it appears to save and restore the window geometry just fine. Only when set to Large it defaults to a different size.

I'm using Awesome window manager with a fair number of modifications, but in its current configuration it doesn't do anything to influence the position or size of new windows.

Martin Owens (doctormo) wrote :

Hyper, could you get inkscape into it's erroneous state, exit and post the peferences.xml to this bug report? I'll debug the issue and see if there's anything we can do to fix it.

Martin Owens (doctormo) on 2013-06-16
Changed in inkscape:
status: New → Incomplete
Michael-gr (grosberg-michael) wrote :

I wanted to add "confirmed on Windows 7" but it's more complicated than that, it appears.

I had the same thing, no matter what I did to the window the next time I opened the file it reverted to a large size (specifically 75% of my current desktop) - and although it didn't appear to fill the entire desktop the window behaved as if it was maximized, i.e. there was a "restore down" button instead of the "maximize" button and the window could not be moved.

After changing the Default size setting from Large to Small this appears to be solved. However now that I tried to change it back to large and attempt to reproduce I found out the problem is gone completely.

su_v (suv-lp) on 2013-10-17
Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

Removing milestone 0.91 - lacks data requested from the original reporter to allow further investigation.

Changed in inkscape:
milestone: 0.91 → none
su_v (suv-lp) wrote :

On 2013-06-14 04:56 (+0100), HyperHacker wrote:
> I'm using nightly trunk builds (Lubuntu 12.10 on AMD64);

Is this still an issue with recently released Inkscape 0.91? If so, any chance you could attach Inkscape's preferences file of such a state as described in comment #3?

Patrick Storz (ede123) wrote :

In fact I'm seeing a very similar issue in Inkscape 0.91 on Windows 7.

At least for my platform I found the cause of the issue:
- If Inkscape's default window size is set to "large" it's size is set to about 75% of desktop width/height.
- However the width/height of the desktop is calculated as the total width/height of all displays attached!

For example if you have two displays connected and set-up with a side-by-side layout, Inkscape's window will be much too wide to fit on a single display on startup. Similarly if you have arranged the displays on top of each other the window will be much too high.

I think the best solution would be to detect the width/height of the display Inkscape is going to be displayed on initially and use those dimensions to calculate the initial window size.
If this is not (easily) possible it would probably be an alternative to detect the dimensions of the *smallest* attached display and use those for calculation.

jazzynico (jazzynico) on 2015-03-09
Changed in inkscape:
importance: Undecided → Wishlist
status: Incomplete → Triaged
tags: added: preferences
su_v (suv-lp) on 2015-10-15
Changed in inkscape:
milestone: none → 0.92
jazzynico (jazzynico) on 2016-05-30
Changed in inkscape:
milestone: 0.92 → 1.0
assignee: nobody → jazzynico (jazzynico)
Patrick Storz (ede123) wrote :

This bug is fixed in r15507
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15507

Let me know if any issues remain.

If not I suggest to back-port to 0.92.x.

Patrick Storz (ede123) on 2017-02-11
Changed in inkscape:
assignee: jazzynico (jazzynico) → Eduard Braun (eduard-braun2)
jazzynico (jazzynico) on 2017-02-11
Changed in inkscape:
milestone: 1.0 → 0.93
status: Triaged → Fix Committed
Patrick Storz (ede123) wrote :
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers