Inkscape-trunk crash on Mageia Linux Cauldron x86-64

Bug #1190072 reported by Shlomi Fish on 2013-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Martin Owens

Bug Description

Inkscape-trunk crashes right on the startup on Mageia Linux Cauldron x86-64 on KDE 4. Here is the backtrace

shlomif@telaviv1:~$ gdb ~/apps/graphics/inkscape-trunk/bin/inkscape
GNU gdb (GDB) 7.6-3.mga4 (Mageia release 4)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-mageia-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/shlomif/apps/graphics/inkscape-trunk/bin/inkscape...done.
(gdb) r
Starting program: /home/shlomif/apps/graphics/inkscape-trunk/bin/inkscape
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffe8bb2700 (LWP 18354)]
[New Thread 0x7fffe83b1700 (LWP 18355)]
[New Thread 0x7fffe7bb0700 (LWP 18356)]
Detaching after fork from child process 18358.
Detaching after fork from child process 18359.
[New Thread 0x7fffe32dd700 (LWP 18360)]
Unable to find: FullScreen

** (inkscape:18348): WARNING **: Unknown verb name: FullScreen
Unable to find: FullScreenFocus

** (inkscape:18348): WARNING **: Unknown verb name: FullScreenFocus
Unable to find: FullScreen
terminate called after throwing an instance of 'Gtk::IconThemeError'

Program received signal SIGABRT, Aborted.
0x00007ffff145ba65 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: debuginfo-install lib64atkmm1.6_1-2.22.7-1.mga4.x86_64 lib64atlas3-x86_64-3.8.4-2.mga3.x86_64 lib64cairomm1.0_1-1.10.0-2.mga3.x86_64 lib64fftw3-3.3.3-3.mga3.x86_64 lib64gc1-7.3-0.alpha4git.3.mga3.x86_64 lib64glibmm2.4_1-2.36.2-1.mga4.x86_64 lib64gsl0-1.15-7.mga4.x86_64 lib64gtk-engines2-2.20.2-5.mga3.x86_64 lib64gtkmm2.4_1-2.24.2-6.mga3.x86_64 lib64lcms2_2-2.4-3.mga3.x86_64 lib64lqr0-0.4.1-5.mga3.x86_64 lib64magick-6Q16_1-6.8.5.10-1.mga4.x86_64 lib64pangomm2.4_1-2.34.0-1.mga4.x86_64 lib64popt0-1.16-4.mga3.x86_64 lib64sigc++2.0_0-2.2.11-3.mga3.x86_64 lib64xslt1-1.1.28-2.mga3.x86_64
(gdb) bt
#0 0x00007ffff145ba65 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007ffff145d0c8 in __GI_abort () at abort.c:90
#2 0x00007ffff1d4d67d in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
#3 0x00007ffff1d4b776 in __cxxabiv1::__terminate (handler=<optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:40
#4 0x00007ffff1d4b7a3 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:50
#5 0x00007ffff1d4b9ce in __cxxabiv1::__cxa_throw (obj=0x4ad5280,
    tinfo=<optimized out>, dest=<optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:83
#6 0x00007ffff4dbca5f in Gtk::IconThemeError::throw_func(_GError*) ()
   from /lib64/libgtkmm-2.4.so.1
#7 0x00007ffff57e0bb2 in Glib::Error::throw_exception(_GError*) ()
   from /lib64/libglibmm-2.4.so.1
#8 0x00007ffff4dbd2cd in Gtk::IconTheme::load_icon(Glib::ustring const&, int, Gtk::IconLookupFlags) const () from /lib64/libgtkmm-2.4.so.1
#9 0x0000000000cadd59 in MarkerComboBox::add_markers(_GSList*, SPDocument*, int) ()
#10 0x0000000000cae089 in MarkerComboBox::sp_marker_list_from_doc(SPDocument*, int) ()
#11 0x0000000000caebff in MarkerComboBox::init_combo() ()
#12 0x0000000000caf292 in MarkerComboBox::MarkerComboBox(char const*, int) ()
#13 0x0000000000bcb140 in Inkscape::StrokeStyle::StrokeStyle() ()
#14 0x0000000000bcb953 in sp_stroke_style_line_widget_new() ()
#15 0x0000000000a60ffc in Inkscape::UI::Dialog::FillAndStroke::FillAndStroke()
    ()
#16 0x0000000000a35ea2 in Inkscape::UI::Dialog::PanelDialog<Inkscape::UI::Dialog::Behavior::DockBehavior>* Inkscape::UI::Dialog::PanelDialog<Inkscape::UI::Dialog::Behavior::DockBehavior>::create<Inkscape::UI::Dialog::FillAndStroke>() ()
#17 0x0000000000a30409 in Inkscape::UI::Dialog::Dialog* Inkscape::UI::Dialog::(anonymous namespace)::create<Inkscape::UI::Dialog::FillAndStroke, Inkscape::UI::Dialog::Behavior::DockBehavior>() ()
#18 0x0000000000a312c2 in Inkscape::UI::Dialog::DialogManager::getDialog(unsigned int) ()
#19 0x0000000000a3137a in Inkscape::UI::Dialog::DialogManager::showDialog(unsigned int) ()
#20 0x00000000007e4a0a in sp_action_perform(SPAction*, void*) ()
#21 0x00000000008f245e in SPDesktop::show_dialogs() ()
#22 0x00000000006b34ed in sp_namedview_window_from_document ()
#23 0x000000000090f256 in sp_file_new(Glib::ustring const&) ()
#24 0x000000000090f571 in sp_file_new_default() ()
#25 0x0000000000697556 in sp_main_gui(int, char const**) ()
#26 0x00007ffff1448ba5 in __libc_start_main (main=0x683300 <main>, argc=1,
    ubp_av=0x7fffffffd288, init=<optimized out>, fini=<optimized out>,
    rtld_fini=<optimized out>, stack_end=0x7fffffffd278) at libc-start.c:258
---Type <return> to continue, or q <return> to quit---
#27 0x0000000000694541 in _start () at ../sysdeps/x86_64/start.S:123
(gdb)

I build inkscape-trunk using this command:

<<<
#!/bin/bash
cmake -G Ninja -DCMAKE_INSTALL_PREFIX="$HOME/apps/graphics/inkscape-trunk" -DENABLE_LCMS=OFF -DCMAKE_CXX_FLAGS="-fpermissive" -DENABLE_POPPLER=OFF -DENABLE_POPPLER_CAIRO=OFF ../inkscape/
>>>

And then I ran ninja. Tried rebuilding from scratch - does not help.

Shlomi Fish (shlomif-gmail) wrote :

Note that on LXDE on :1, ~/apps/graphics/inkscape-trunk/bin/inkscape starts inkscape fine, so it may be a theme problem or whatever.

Martin Owens (doctormo) wrote :

I've put in fixes for the crash and the missing icon. Please test r12369. for working icon in marker drop-down on windows and LXDE and if working I'll Fix Commit this bug.

Changed in inkscape:
status: New → In Progress
assignee: nobody → Martin Owens (doctormo)
su_v (suv-lp) on 2013-06-12
tags: added: crash regression ui
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.49
Shlomi Fish (shlomif-gmail) wrote :

This seems fixed at r12370:

------------------------------------------------------------
revno: 12370
fixes bug: https://launchpad.net/bugs/357043
committer: Martin Owens <email address hidden>
branch nick: inkscape
timestamp: Tue 2013-06-11 23:48:35 -0400
message:
  Fix Apache2 license conflict with GPL with re-license from SOIX upstream
------------------------------------------------------------
revno: 12369
fixes bug: https://launchpad.net/bugs/1190072
committer: Martin Owens <email address hidden>
branch nick: inkscape
timestamp: Tue 2013-06-11 20:04:45 -0400
message:
  Use 'remove' instead of 'gtk-remove' for theme.
------------------------------------------------------------

inkscape no longer crashes on startup - thanks for the quick fix.

su_v (suv-lp) on 2013-06-12
Changed in inkscape:
milestone: 0.49 → none
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers