Cannot cut and paste

Bug #1181252 reported by Derek Matsuura on 2013-05-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Have been using Inkscape on this computer for about a year and a half, no issues, stable. Windows did a 5.16.13 update then cut and paste started acting strangely. Difficulty cnp photos from one window to another, then eventually complete failure to do so. Can still seem to cnp within same window. Sometimes will result in runtime error leading to windows closing application. Windows 7 Version 6.1 (Build 7601: Service Pack 1)

su_v (suv-lp) on 2013-05-17
tags: added: clipboard win32
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP, Inkscape 0.48.4 and trunk revision 12387.
Could you please give your Inkscape version?

Apparently, there are known issues with CnP on Windows 7 (see [1]) Would some of the tips suggested in the MS Technet thread fix your issue?

[1] http://social.technet.microsoft.com/Forums/windows/en-US/5bbc11e8-ca2d-41ac-b640-d66ce971f58f/copy-paste-clipboard-issues-not-working

Changed in inkscape:
importance: Undecided → Medium
status: New → Incomplete
Kris (kris-degussem) wrote :

No issue noticed (vista 64 bit, trunk r12481).
Closing by lack of user feedback.
Feel free to reopen this report when the issue reappears.

Changed in inkscape:
status: Incomplete → Invalid

Having same problem, Win 7 Professional 64 bit, Inkscape 0.48.4 r9939.

When attempting to paste, Inkscape status bar says "Nothing on the clipboard". I've tried running in XP compatibility mode and running Inkscape as admin.

Trying to CTRL-C copy or trying to copy using the right click menu on an object makes no difference, the user always sees "Nothing on the clipboard" when attempting to paste. I'll continue to investigate.

Changed in inkscape:
status: Invalid → Confirmed

Inkscape IS putting content on the clipboard -- I can see it with a utility called "Clipboard Format Spy" (attaching screenshot). When trying to paste, Inkscape says there's nothing on the clipboard.

Beluga (buovjaga) wrote :

Is this still happening with 0.91 or 0.92?

To be honest, I can't quite recall as it has been three and a half years.
But I've got a project to do this weekend, so will check and see. Thanks!

Derek

On Fri, Sep 2, 2016 at 11:47 AM, Beluga <email address hidden> wrote:

> Is this still happening with 0.91 or 0.92?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1181252
>
> Title:
> Cannot cut and paste
>
> Status in Inkscape:
> Confirmed
>
> Bug description:
> Have been using Inkscape on this computer for about a year and a half,
> no issues, stable. Windows did a 5.16.13 update then cut and paste
> started acting strangely. Difficulty cnp photos from one window to
> another, then eventually complete failure to do so. Can still seem to
> cnp within same window. Sometimes will result in runtime error
> leading to windows closing application. Windows 7 Version 6.1 (Build
> 7601: Service Pack 1)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/1181252/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers