Batch export DPI always at 90.

Bug #1158506 reported by Ron Novy on 2013-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
jazzynico

Bug Description

Using Inkscape 0.48.4 r9939 on Windows.

As far as I can tell there is no way to change the DPI for batch exports. In my opinion, this is a bug and not just a missing feature. I'm attempting to export a large group of images at 300 to 600 DPI that originate from different groups in the same document. Doing each one by hand is very tedious and there are about 100 documents with about 100 groups to export from each.

My only workaround is to increase the document size to the max of 4096x4096 and stretch everything to that size, but the exports are still way too small. Scaling the resulting batch exported files to the size I need would not help and defeats the purpose of using vector art in the first place.

Enabling the option to change the DPI would be a huge help here.

su_v (suv-lp) on 2013-03-21
tags: added: bitmap exporting
removed: batch dpi export
su_v (suv-lp) wrote :

> In my opinion, this is a bug and not just a missing feature.

The current behavior works as originally intended:
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.46#Bitmap_export>
and as documented in the manual:
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/File-Export.html#id1134260>

«The resolution will be 90 dpi unless previously saved with a different dpi.»

-> IMHO this is a request for a new feature, not an actual bug.

Ron Novy (ron-novy) wrote :

Ok, maybe I jumped into calling it a bug because I was getting frustrated. After investigating further, I still can't batch export the way I want without some serious effort.

Options:
I could follow the manual but I'd be back where I started with the default 90DPI.

If I select each individual group to export, one by one, setting the options and then exporting, I can save the main SVG and the file names will be saved for future batch exporting... But then what's the point of having a batch export when I just did them one by one and I'm only doing this once?

I can set the export properties of all of them at once by selecting all the groups and then export them all to a single file large file. This saves the DPI values I set for each individual group, but then when I go back and do the batch export, it has set the file name of every group to the same name and so it overwrites the file 100 times... That sounds like a bug.

Unless I'm missing something, my best option is to select all groups and export to one file with the settings I want. Then close the SVG and edit it in a text editor to replace the lines defining the file name with an empty line. Then save and load the SVG back into Inkscape and do a batch export.

Please don't take any of that as me being hostile. It's just a very frustrating workflow and I want to be sure it's understood. I do admit that editing the file works, but it's not the way I would expect to have to make it work. It's also not the way that I expected batch export to work.

Thank you,
Ron

Marek Halmo (halmomarek) wrote :

Same issue here..

I want to create game elements(120) in inkscape and be able to support multiple dpi.

What i need to do is to create the elements in inkscape, make each element a group with proper name..
Set target file name for element (for me same as id, without the path)
in inkscape settings - i set default dpi for export
select all elements, export, batch export

All elements are exported, but they are in 90 dpi (which is wrong).. should be 240

idealy the dpi setting should be enabled in batch export.

As i need to create the elements in multiple dpi - so i need to export all 120 elements in 120dpi, 160dpi, 240dpi..
what you suggest is that i change the dpi to 120/160/240 on all 120 game elements.. that is a lot of work!

Please add this feature or use the default setting in inkscape preferences.. :(

Hi,

This post is old but just to point out that multiple dpi can be achieved in command line mode. I wrote a small python script that can be used to export a list of objects in multiple dpi. Hope this help.

https://gist.github.com/lzubiaur/9074270

Regards, Laurent

jazzynico (jazzynico) wrote :

Suggesting to replace:
«The resolution will be 90 dpi unless previously saved with a different dpi.»
with:
«The resolution will be the one defined in the bitmap export preference unless previously saved with a different dpi.»

Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
jazzynico (jazzynico) wrote :

Patch attached (tested on Windows XP, trunk revision 13156).

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
su_v (suv-lp) wrote :

Testing with revision r13156 on OS X 10.7.5: Currently, I have trouble to have the export dialog use a default export resolution value from the prefs changed in the current session (it seems to work ok after restarting inkscape, but during the current session the batch export AFACIT falls back to 90dpi after having changed the preference setting).

jazzynico (jazzynico) wrote :

Fix committed revision 13160.

The Export dialog has some difficulties to synchronize its fields with the general preferences (the file path entry is also affected, see Bug #1153829 - Export selection won't remember last used file name).
Since it has nothing to do with the patch, I'm committing it anyway. Feel free to reopen the report if I'm wrong.

Changed in inkscape:
milestone: none → 0.91
status: Confirmed → Fix Committed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers