Inkscape save PostScript with wrong level

Bug #1157064 reported by Oleg Koptev on 2013-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
Inkscape Devlibs
Medium
jazzynico

Bug Description

This is not duplicate of bug #698340.

When I save in PS/EPS, Inkscape save it in PostScript Level 2, no matter if I choose Level 2 or Level 3 in save settings.
In attachment there are two files I saved with diferent options - the difference only in creation time.

System: Win7 x64
Inkscape 0.48+devel r12093

Oleg Koptev (koptev-oleg) wrote :
su_v (suv-lp) wrote :

For the ease of testing, could you attach the original SVG file, too?

tags: added: exporting ps
description: updated
tags: added: eps
Oleg Koptev (koptev-oleg) wrote :

Sure thing

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.4 and trunk revision 12224 (cairo 1.11.2).
Not reproduced with a modified trunk version, with cairo 1.12.8.

Very likely an issue in our current cairo version. Should be fixed next time we update the devlibs.

Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
Changed in inkscape-devlibs:
importance: Undecided → Medium
status: New → Triaged
su_v (suv-lp) wrote :

> Not reproduced with a modified trunk version, with cairo 1.12.8.

Can't confirm this with 0.48.x and trunk on OS X 10.7 using cairo 1.12.2 and cairo 1.12.14: the provided sample SVG file (containing just 2 filled, unstroked paths) exports to PostScript Language Level 2, no matter which version is selected in the export options dialog.
The comment in the header section of the generated PostScript file(s) is always the same:
%%LanguageLevel: 2

Note that according to this page:
<http://cairographics.org/documentation/using_the_postscript_surface/>
setting the level only makes sure to conform to the specified level, not which level is actually used:
«Note that when when Language Level 3 is permitted the, "LanguageLevel" DSC comment in the output may still indicate 2 if no level 3 features are used.»

AFAIU based on above description, there is no way for Inkscape to force cairo to generate a level 3 PostScript file, if no specific level 3 features are used.

jazzynico (jazzynico) wrote :

Note that I didn't test with the attached file, but with a local file that contains gradients. I guess that's why the generated EPS file shows %%LanguageLevel: 3 (even if the gradient is converted to bitmap).
With cairo 1.11.2, the same file (with gradient) always gives a level 2 EPS file.

jazzynico (jazzynico) wrote :

Not reproduced on Debian Testing (cairo 1.12.2) and Windows XP (cairo 1.12.14) with the attached file (gradient fill).

%%LanguageLevel is set according to the chosen option.

jazzynico (jazzynico) wrote :

Fixed for win32, devlibs r46.

Changed in inkscape-devlibs:
status: Triaged → Fix Released
su_v (suv-lp) wrote :

Reopening for 32bit Windows devlibs - the cairo update of r46 was reverted in r47 due to regressions (see e.g. bug #1351597).

Changed in inkscape-devlibs:
status: Fix Released → Triaged
jazzynico (jazzynico) wrote :

Cairo (1.14.6) and Pixman (0.34.0) updated in the official win32 devlibs rev. 61.

Changed in inkscape-devlibs:
assignee: nobody → jazzynico (jazzynico)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers