Missing language list in po/Makefile

Bug #1134042 reported by Janis Eisaks on 2013-02-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
su_v

Bug Description

Some time after 14.02.2013 the list of interface languages disappeared form the po/Makefile (variable ALL_LINUGUAS is empty) after ./configure.

I have an automatic retrieval and compilation system triggered by inkscape.pot changes and after the latest .pot update the NLS support is not compiled. In the same time, source code tree pulled on 14.02.2013 still compiles as expected.

Attached - configure logs for 14.02.2013 and 27.02.2013 branches

Janis Eisaks (jancs) wrote :
Janis Eisaks (jancs) wrote :

P.S. I compared autogen.sh scripts - the latest is extremely small - 10 x smaller than one of 14.02.2013

su_v (suv-lp) wrote :

See also comments #24-28 in bug #992047 about the same issue with updated autotools build system (r12150)
<https://bugs.launchpad.net/inkscape/+bug/992047>

Janis Eisaks (jancs) wrote :

P.S.2
after running autogen.sh in 14.02.2013 branch the following lines are showing up in configure:
# grep "catalogs to be installed" *

aclocal.m4: AC_MSG_CHECKING(for catalogs to be installed)
configure: { $as_echo "$as_me:${as_lineno-$LINENO}: checking for catalogs to be installed" >&5
configure:$as_echo_n "checking for catalogs to be installed... " >&6; }

i tried to put autogen.sh in to 27.02 version, but it gave no result.

su_v (suv-lp) on 2013-02-27
tags: added: build i18n translation
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2013-02-27
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

> If it can help - here are mine autogen logs

The issue is known, and AFAIU triggered by moving from Glib's gettext to upstream gettext (see also the brief discussion in <https://code.launchpad.net/~jjardon/inkscape/autotools/+merge/77850>).

Quoting my comment (#27) from bug #992047:
<quote>
> rev >= 12150 no longer seems to install po files anymore…

AFAIU this is fixed by adding the file po/LINGUAS (same information formerly stored in the variable "ALL_LINGUAS" in configure.ac).

After adding the file, the translation files (*.mo) are processed and installed, but gettext still gets the destination directory wrong (DATADIRNAME is 'lib' instead of 'share'), at least on OS X (possibly related to bug #398571 (?)).
</quote>

Link to sample 'po/LINGUAS' file (tested with r12155 on Ubuntu 12.10 and OS X 10.7.4):
<https://bugs.launchpad.net/inkscape/+bug/992047/+attachment/3548730/+files/LINGUAS>

Janis Eisaks (jancs) wrote :

How much upstream gettext do you use? Is the 0.18.2 upstream enough?

su_v (suv-lp) wrote :

@Alex - could you review the attached diff (which adds the missing file)?

(created based on information from e.g. <https://live.gnome.org/GnomeGoals/PoLinguas>,
tested successfully on Ubuntu 12.10 with Inkscape 0.48+devel r12155)

Alex Valavanis (valavanisalex) wrote :

Linguas list seems to be detected correctly with the patch. Committed in lp:inkscape r12156

Changed in inkscape:
assignee: nobody → ~suv (suv-lp)
status: Confirmed → Fix Released
su_v (suv-lp) wrote :

@JazzyNico - does this change (move list of available languages from 'configure.ac' to 'po/LINGUAS') require any updates to the translation pages in the wiki?

jazzynico (jazzynico) wrote :

@~suv - There's currently nothing about it in the wiki. I guess we should add something in case we add a new translation.
One more line in my todo list...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers