JessyInk zipped pdf or png output should allow low resolution values

Bug #1126472 reported by pRototype on 2013-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico
JessyInk
Low
Hannes Hochreiner

Bug Description

Tested on Windows 7 with:
Inkscape 0.48.4 r9939
and
Inkscape 0.48+devel r12122

Same result on both versions.

If I try to change resolution to somethinge else than 50dpi, then the number in the input box change it back to 50 then I save, or if changing focus forth and back to the dpi/png/pdf dialog box.

Related branches

jazzynico (jazzynico) wrote :

Not reproduced on Windows XP, Inkscape 0.48.4 and trunk revision 12237.
Maybe another Windows 7 specific issue.

tags: added: exporting extensions-plugins
jazzynico (jazzynico) wrote :

Not reproduced on Windows 7, Inkscape trunk revision 12241.

Could you please attach an example file that fails on your computer?

Changed in inkscape:
status: New → Incomplete
pRototype (regeir) wrote :

I've tested on an old XP computer and I do reproduce the bug.
Inkscape 0.48+devel r12228

However, since you couldn't reproduce, I had to think over this a little. It seems that the bug does occur when the following factors is true:
* Default unit is CM
* Stroke Width on objects is given in CM
* Three layers (in sample file, there is one object per layer)
* Page size is given in CM (Bug #1076428 still occur in this file)
* Grid spacing in both X and Y directions is set to 0,1 cm

jazzynico (jazzynico) wrote :

Still not reproduced on Windows XP with the file attached comment #3.

But I've just noticed the minimum value is 50 (hard-coded in the extension, but can be modified in the trunk). Does it fail with lower values only or also with higher ones?

pRototype (regeir) wrote :

JazzyNico got it right. I now see that 50 DPI is a lower limit.

I cannot see any reason having such low limit. I often deals with drawings that having size in meters (some houndred cm in both directions). Exporting those drawings with 50 DPI will create pictures that has very large dimensions.
Having pictures that measures some hundreds mpx is not very handy to open on this very old machine wich has only 512 MB RAM. However, exporting with DPI 50 or higher works just fine.

I did a very important observation on this old low-spec machine. When I first saved as Jessy-ink zip with 76 dpi, The zip file just wasn't created, aparently. I did save the file (as jassy-ink zip) three times with just slightly different dpi value and could still not observe that any file was created as I expected.
However, after restarting the computer, the jessy-ink zip file was present in the folder where I choosed it to be created.
I use the term "very important" because a user may expect loss of data, and I also expect that if Windows goes in BSOD, that will cause windows to never create the file.

I guess this is an XP issue with files that is written, but for some reason isn't properly created on file system before log off.

jazzynico (jazzynico) wrote :

@pRototype - I have no experience with wide posters. What would be an acceptable low value for you?
@Hannes - What's your take on lowering the export resolution limit in JessyInk?

summary: - JessyInk zipped pdf or png output - cannot change resolution
+ JessyInk zipped pdf or png output should allow low resolution values
Changed in inkscape:
importance: Undecided → Low
status: Incomplete → Triaged
pRototype (regeir) wrote :

HI.

For one spesific project, I export all png with 36 dpi. But - If I was drawing something bigger - a house in real length, I would need to be able to set the DPI very low. Probably lower than 5.

My idea is that it shouldn't be any dpi limit at all. Well, maybe a warning with an option to cancel the operation if the dimension of output images gets very large.

I do not recall my original reasoning for choosing the value I chose, but I don't see any problem with lowering the lower limit for the resolution value. I guess there is no point in having a value smaller than 1, so what about 1?

Changed in jessyink:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Hannes Hochreiner (hannes-hochreiner)
pRototype (regeir) wrote :

I think a value of 1 should be just fine.

Thanks

jazzynico (jazzynico) on 2013-07-02
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Triaged → In Progress
Changed in jessyink:
milestone: none → 1.5.6
status: In Progress → Fix Committed

Adapted the Inkscape extension file (jessyInk_export.inx). Set the lower bound for the export resolution from 50 to 1. This should fix the problem.

jazzynico (jazzynico) wrote :

Fixed in the trunk, revision 12709.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers