Inkscape crashes while working with text tool (win32)

Bug #1122374 reported by uwesch on 2013-02-11
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Inkscape development version R12118 crasehs in windows 7 while working with text tool.

Start inkscape
Click menu text --> font & text to open text dialog
Click text tool (F8)
Click drop down field in tool control bar

Inkscape crashes.

Start inkscape
Create a simple text with text tool (F8).
Open text dialog
choose another font

Inkscape crashes with error 177 (see attached png "error_r12118.png")

Inkscape also crashes with error 144 (see attached png "error_r12118_1.png")

uwesch (uwesch) wrote :
uwesch (uwesch) wrote :

the second error.

su_v (suv-lp) wrote :

Not produced on:
- Ubuntu 12.10, GTK+/X11, cairo 1.12.2, pango 1.30.1
- Mac OS X 10.5.8 (i386), GTK+/X11, cairo 1.10.2, pango 1.28.4
- Mac OS X 10.5.8 (i386), GTK+/Quartz, cairo 1.11.4, pango 1.28.4
- OS X 10.7.4, GTK+/X11, cairo 1.12.2, pango 1.30.1
- OS X 10.7.4, GTK+/Quartz, cairo 1.12.14, pango 1.32.5

tags: added: crash fonts regression win32
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.49
Alvin Penner (apenner) wrote :

not reproduced on Windows XP, Inkscape rev 12119

su_v (suv-lp) wrote :

Related (likely a duplicate):
- Bug #1122839 “0.49 crashes after applying "Replace font" extension”
  <https://bugs.launchpad.net/inkscape/+bug/1122839>

uwesch (uwesch) wrote :

Not reproduced on another windows 7 with R12119.

Please close the bug.

Changed in inkscape:
status: New → Invalid
su_v (suv-lp) wrote :

According to latest comment in bug #1122839
<https://bugs.launchpad.net/inkscape/+bug/1122839/comments/3>
the issue seems not to be reliably reproducible:

> ..however, I also can't reproduce it reliably. Sometimes it crashes,
> sometimes it doesn't. Sometimes only when we use "Select same" ->
> "Object type" (which is text) and then select the drop-down list

and may also depend on the content of the current document (not confirmed).

Please reopen this report if the crash reoccurs with r12119 or later revisions.

uwesch (uwesch) wrote :

Even in R12125 inkscape crashes in windows 7 if I work with the tool control bar.

su_v (suv-lp) wrote :

Reopening, and confirmed by duplicate report (bug #1122839).

Changed in inkscape:
status: Invalid → Confirmed
uwesch (uwesch) wrote :

(inkscape.exe:3784): Pango-WARNING **: couldn't load font "Symbol 9", falling back to "Sans 9", exp
ect ugly output.

(inkscape.exe:3784): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the
offending font is 'Broadway 9'

(inkscape.exe:3784): Pango-WARNING **: font_face status is: <unknown error status>

(inkscape.exe:3784): Pango-WARNING **: scaled_font status is: <unknown error status>

su_v (suv-lp) on 2013-02-14
summary: - Inkscape crashes while working with text tool
+ Inkscape trunk crashes while working with text tool

@all - does this still happen as described with current Windows snapshot builds?

DerRuhri (no-ads-please) wrote :

System: Windows 7 Enterprise, 64 bit, SP 1, German

Inkscape nightly, r 12605 (2013-09-28, latest currently available from Skydrive)

-> no more crashes

su_v (suv-lp) wrote :

A confirmation from at least one other user would be great ;-)

Setting bug status to 'Incomplete' for now.

Changed in inkscape:
status: Confirmed → Incomplete
su_v (suv-lp) wrote :

Closing - feel free to reopen if the crash still occurs with current development snapshot builds for Windows.

Changed in inkscape:
status: Incomplete → Invalid
su_v (suv-lp) on 2013-10-19
Changed in inkscape:
milestone: 0.49 → none
jazzynico (jazzynico) wrote :

Reopening (duplicate Bug #1259100 "Inkscape crashes while browsing fonts").

Changed in inkscape:
status: Invalid → New
jazzynico (jazzynico) wrote :

Console messages from Bug #1259100.

Cojnel (cojnel) wrote :

Inkscape doesn't crash,
but the terminal messages are the same as jazzynicos in comment #16.

Tested with r12960 on linux mint 15 32bit.

After starting inkscape and choosing Text > Text and Font,
or if inkscape is restarted with the Text and Font dialog open (either docked or not),
the terminal starts outputting:
(inkscape:4127): Gtk-CRITICAL **: gtk_list_store_get_value: assertion `VALID_ITER (iter, list_store)' failed
(inkscape:4127): GLib-GObject-CRITICAL **: g_value_get_string: assertion `G_VALUE_HOLDS_STRING (value)' failed
(inkscape:4127): GLib-GObject-CRITICAL **: g_value_unset: assertion `G_IS_VALUE (value)' failed
(inkscape:4127): Gtk-CRITICAL **: gtk_list_store_iter_next: assertion `GTK_LIST_STORE (tree_model)->stamp == iter->stamp' failed
** (inkscape:4127): WARNING **: Couldn't find row for style: Normal (sans-serif)

the messages above,
repeat when performing alot of different actions,
for instance:
drawing a rubberband selection with the selection tool and releasing the mouse button.
switching to the node editing tool or the text tool in the toolbox (from any other tool).
clicking on the canvas with any of these tools:
node editing,
rect,
3d box,
ellipse,
star,
spiral,
freehand.
when drawing a path with the bezier tool,
after the first node and when finishing a bezier path
by either pressing the enter key or the right mouse button.
pressing undo.

probably more...
.

Possible reason:
It might have something to do with the default font
"sans-serif",
because if one activates the text tool,
and picks a new font from the dropdown list,
then the critical/warning messages stop.

And after changing the default font,
by opening the Text > Text and Font dialog,
and picking a new font from the left "Font family" list,
i tried Arial, Saab and Sawasdee.

After restarting inkscape,
terminal messages doesn't show up when
the text and font dialog opens.

If sans-serif is set as the default font again,
and inkscape is restarted, then the error messages
return when opening the text and font dialog.

su_v (suv-lp) wrote :

On 2014-01-20 18:59 +0100, Cojnel wrote:> Inkscape doesn't crash,
> but the terminal messages are the same as jazzynicos in comment #16.
>
> Tested with r12960 on linux mint 15 32bit.

@Cojnel - this report specifically tracks a crash (regression) with Windows development snapshot builds. There are other reports (not platform-specific) which deal with issues related to the (new) default font 'sans-serif'.

Krzysztof Kosinski (tweenk) wrote :

The bug is probably caused by stale slots being left in SPDesktop after the TextTool object is destroyed. I committed a fix for hat problem in r13118. If I'm right, the random messages should appear in unfixed builds after this sequence of actions:

1. Open any document
2. Select text tool
3. Select any other tool
4. Select text tool again
5. Draw something, select and move objects, etc.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
Krzysztof Kosinski (tweenk) wrote :

Disregard comment #19, this was not the case. Looks like this problem is related to the font list and not to the tool callbacks.

Krzysztof Kosinski (tweenk) wrote :

I haven't been able to reproduce the bug so far.

Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → nobody
Bryce Harrington (bryce) wrote :

I wonder if this is something peculiar about the san-serif font itself? Perhaps it includes features or functionality that cairo is unable to deal with?

Could someone with an affected system upload their san-serif font ttf file? If I'm right, then it should be reproducible on linux if this font is installed.

Changed in inkscape:
status: New → Incomplete
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 13828, after scrolling the fonts in the Text and font dialog and in the text tool's control bar many times (the crash occurred when opening the list in the control bar).
Unfortunately the console didn't return anything useful and I was not running Inkscape in GDB.

Changed in inkscape:
status: Incomplete → Confirmed
Brynn (brynn4inks) wrote :

Well, this is happening for me as well. Windows7, sp1, 64-bit using Inkscape 0.91 32-bit (exe installer)

Yesterday, it all but crashed my whole computer. It was essentially frozen, and I did have to restart, to regain control. Today, it only crashed Inkscape. Specifically, it happens to me when scrolling the font menu with Text tool. I do not have the Text and Font dialog open, and I haven't tried the Replace Fonts extension.

The error message I get is exactly the same as in Comment #1. (so I won't attach a screenshot)

It doesn't happen every time. I was using the Text tool and browsing the font menu a few days ago, with no problems. And while I got the error message 15 minutes ago, just now I was able to browse the font menu without any errors.

Please let me know if I can provide further info or files or logs, or whatever. Or I'll be happy to test, if I can.

Thank you very much :-)

Mel (mel47) wrote :

I am having this issue as well. Using the drop-down text font menus (either from toolbar or the Text and Font dialog box) crashes Inkscape 0.91 (for 32-bit) in Windows 7 Professional SP1 (32-bit).

My default font I am using is Calibri (not sans-serif). And when I scroll down to choose another font, the application crashes with a Code 177 error report when I am scrolling down the font menu. Upon re-opening Inkscape and trying again, it will sometimes work and not crash but will always crash at least once or twice during each new Inkscape application use, or using an existing .svg file.

su_v (suv-lp) on 2015-09-03
summary: - Inkscape trunk crashes while working with text tool
+ Inkscape trunk crashes while working with text tool (win32)
su_v (suv-lp) on 2015-10-15
Changed in inkscape:
milestone: none → 0.92

This is driving me nuts! How can I fix this assertion failed crap? I am having the same exact problem everyone else is and I don't know what to do.
Assertion Failed
File: cairo.c
Line: 177
Expression: _cairo_status_is_error (status)
I have windows 10 now but it was happening when I had windows 7 as well.
I am so confused. Any help would be greatly appreciated!
Thanks!

Tavmjong Bah (tavmjong-free) wrote :

I've poked around the code and don't see anything obvious. Some comments:

1. 'sans-serif' is a generic CSS font value. Pango will substitute an appropriate font which will be system dependent.

2. The font back-end is different on Windows from Linux/MacOS so it is not surprising that this only causes crashes on Windows.

3. The Cairo "Assertion Failed" messages are unfortunately almost useless in debugging this problem.

4. It would be really helpful to have a backtrace. If someone can reproduce the crash, please run Inkscape under gdb.

5. What font is actually being used under Windows with 'sans-serif'? Does it have Italic and Bold variants?

jazzynico (jazzynico) wrote :

Some answers:

1. On my Windows XP system, the default font is DejaVu Sans.
4. Running Inkscape in GDB causes a crash as soon as I open the drop-down menu (after some cairo warnings). Not sure it's exactly the same issue. Backtrace attached.
5. DejaVu Sans is installed with all variants.

Tavmjong Bah (tavmjong-free) wrote :

Hmm, the backtrace consists of almost all GTK and Pango calls. Only the last two are in Inkscape code.

It looks like its using Pango with an invalid font. It would be interesting to know what text Pango is trying to output in
pango_itemize_with_base_dir() (third argument)

jazzynico (jazzynico) on 2017-01-04
Changed in inkscape:
milestone: 0.92 → 0.93
su_v (suv-lp) on 2017-01-24
summary: - Inkscape trunk crashes while working with text tool (win32)
+ Inkscape crashes while working with text tool (win32)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers