Connection tool get molasses slow with just ~10 nodes

Bug #1119810 reported by Maneesh Yadav on 2013-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I wanted to use inkscape as a graph editor and draw some shapes with connection tool lines between them. The first few go along fine, but no matter what I do, by (about) node 8 things start slowing down to the point where it is incredibly difficult to actually draw a connection between two shapes, since inkscape has slowed down to the point where it can't update the real time line before it is "set".

This is very repeatable on my MacBook Air, Max OS X 10.7.5, 1.8Ghz Core i5, 4 Gigs.

I downloaded the lastest stable release, which the link says should be 0.48.4...but when I install the about screen says 0.48.2 r9819.

This behavior can be replicated simply:

1. Draw a small circle (I happen to have set the style to a light blue fill and a simple outline).
2. Copy and paste 10 circles randomly around the page (fairly far apart so no risk of overlap).
3. Use the connector tool to start connecting centers of the circles randomly (I'have at least one node with three edges incident to its central connection point).

Things should start freezing up by around node 8. The shape I used doesn't seem to make a difference (e.g. squares).

Alvin Penner (apenner) wrote :

not reproduced on Windows 7, Inkscape 0.48.4 r9939. result is attached
I have never used the connector tool before, so I was not able to get the lines to join the circles centres together. The actual connection point appeared to be random. However I did not experience any slowdown.

Maneesh Yadav (maneeshkyadav) wrote :

Hmmm...after restarting and drawing again I cannot reproduce on my machine.

I'll try doing a few more tests, but perhaps not worth investigating unless I can reproduce again.

Changed in inkscape:
status: New → Invalid
Maneesh Yadav (maneeshkyadav) wrote :

I can reproduce this, it only happens if I do it with my Wacom Bamboo tablet. This could be a deeper problem with the way the tablet sends events to X.

It is odd how it is smooth for the first few connectors, but starts to slow down after a while.

If you have a tablet, please give it a try.

Changed in inkscape:
status: Invalid → New
jazzynico (jazzynico) wrote :

Related or duplicate: Bug #318634 "Wacom's message queue puts CPU to 100%".
<https://bugs.launchpad.net/inkscape/+bug/318634>

tags: added: connectors performance tablet
jazzynico (jazzynico) wrote :

Confirmed on Debian testing, Inkscape trunk revision 12110, core i5 3.4GHz with 8Gio.
No real freeze here, but a relative slowdown around the 20th connector.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments