Inkscape crashes when vectorizing images.

Bug #1117611 reported by Turbo on 2013-02-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Hi all.

I generated several PNG files with Gimp and then imported one into Inkscape, tried to vectorize and always chashed.

This is the Windows version of Inskape, latest and also the SVN crashes too. The sequence to make it fail is:

* Open Inskcape. Import PNG file.
* Menu --> Path --> Vectorize.
* Click on Gray and then Preview.
* A Visual C++ error dialog comes up. Inkscape crashed.

I'm using Windows 7 x86 SP1. Attached you will find the dialog,option and the Visual C++ error, which includes line number and file involved.

Regards.

Turbo.

Turbo (axelhc) wrote :
Turbo (axelhc) wrote :
description: updated
Turbo (axelhc) on 2013-02-06
description: updated
Alvin Penner (apenner) wrote :

- not reproduced on Windows 7, Inkscape 0.48.4
- not reproduced on Windows XP, Inkscape rev 12093

- could you attach the png file?
- did you use embed or link to open the file?
- which rev of Inkscape?

su_v (suv-lp) on 2013-02-06
tags: added: crash tracing win32
Changed in inkscape:
importance: Undecided → High
status: New → Incomplete
Turbo (axelhc) wrote :

Hi,

Using embed. One of the files attached.

Thank you.

Turbo.

su_v (suv-lp) on 2013-02-06
Changed in inkscape:
status: Incomplete → New
su_v (suv-lp) wrote :

Crash not reproduced with Inkscape 0.48.4 on OS X 10.7.4 (64bit build) with embedded bitmap (just for tracing, there's no need to embed it though).

Attaching result based on:
- [x] Colors
- Scans: 3
- [ ] smooth
- [x] remove background

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 12104.
No Visual C++ error dialog, just the usual emergency save message.

No backtrace (always difficult on Windows) but gdb returned the following message:
Program received signal SIGSEGV, Segmentation fault.
0x00bdf6e9 in Inkscape::Trace::Potrace::filterIndexed ()

Changed in inkscape:
status: New → Triaged
jazzynico (jazzynico) wrote :

Same crash with 0.48.3.1 and 0.48.4.

Turbo (axelhc) wrote :

Hi,

Last night I tried againg using Kubuntu 13.04 beta (Kernel 3.8) and there is no crash either. This seems to be a Windows only problem.

Regards

Turbo.

jazzynico (jazzynico) wrote :

Also reproduced with the trunk revision 12119, experimental (but very recent) cross-compiled devlibs from OpenSuse.

Turbo (axelhc) on 2013-02-19
description: updated
jazzynico (jazzynico) wrote :

Reproduced again on Windows XP, inkscape trunk rev. 13963, with the file attached comment #4.

The segfault message is a bit different:
Program received signal SIGSEGV, Segmentation fault.
0x00975a21 in Inkscape::Trace::Potrace::filter(Inkscape::Trace::Potrace::PotraceTracingEngine&, _GdkPixbuf*) ()

jazzynico (jazzynico) wrote :

Not reproduced on Crunchbang Waldorf, Inkscape 0.48.3.1 and trunk rev. 14037.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers