Font not found on system

Bug #1113634 reported by Kristjan Kure on 2013-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Hi!

Using Windows XP Inkscape version 0.48
Im not able to change text to Lane-Narrow font (ttf format).
I have this font under Fonts folder.

Inkscape displays triangle and says "Font not found on system"
In photoshop the font name is displayed "Lane - Narrow".
In Inkscape its "Lane -Narrow". Can this cause the issue - I mean the
minus sign in between?

If I open Text -> Text and font I see correct preview, but if I click
apply it wont apply and Sans font jumps in and displays the result.

I have attached the screenshots

Thank you
Kristjan

Kristjan Kure (kristjanile) wrote :
su_v (suv-lp) on 2013-02-02
tags: added: fonts
removed: font found not on system
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 12149.
The font can be selected in the drop-down list and in the Text and fonts dialog, but still have the warning triangle.

Very close to Bug #667091 "Fonts initially indicated as 'not found on system'".

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Kristjan Kure (kristjanile) wrote :

I want to explain that this issue is not about the warning triangle icon - its about not being able to use some fonts in Inkscape.

I think its because the font name has "-" symbol inside the font name and the program can't handle it. I don't understand why this has low priority if I really can't use the font in my work when I need.

jazzynico (jazzynico) wrote :

@Kristjan Kure - Sorry, I misread your message.

Are you still experiencing the same issue with Inkscape 0.48.4?
I've tested again with that version (the latest official version available) and it seems to be fixed (I still see the triangle, but at least I can select the Lane - Narrow font).

su_v (suv-lp) wrote :

<off-topic>
Basic information about the specific font (e.g. homepage or download link for the font if it's a "free" font) would have been nice - instead of expecting that everyone testing your reported issue does a web search for that font, and by chance ends up testing the same version as you have installed.
</off-topic>

Not really reproduced on OS X 10.7.4 and Ubuntu 12.10, testing the 4 'Lane' fonts downloaded and installed from
<http://www.dafont.com/lane.font>

Inkscape 0.48.4:
- Text Tool controls bar: all four fonts can be assigned and work as expected, even though the font selector on the toolbar complains about not finding the font (because a space gets strip out of the font name displayed in the toolbar: e.g. "Lane -Narrow" instead of "Lane - Narrow"): the text on-canvas is rendered with the selected font nevertheless.
- 'Text and Font' dialog: all 4 fonts can be selected, show a correct preview, and can be assigned to the selected text object.

Inkscape 0.48+devel r12155: same as with stable 0.48 (the modified font name displayed in the toolbar triggers the icon about font not being found, but otherwise does not prevent from using the font)

Kristjan Kure (kristjanile) wrote :

I will add this font now - sorry.

Kristjan Kure (kristjanile) wrote :

I have downloaded the latest version from http://inkscape.org/download/.

1. Please write an example text in Inkscape
2. Open "Text and font" under Text menu.
3. Choose "Lane - Narrow" - the preview will show you the correct visual regarding the example text.
4. If you press Apply its not applied.

So issue remains.

su_v (suv-lp) wrote :

~suv wrote:
> (because a space gets strip out of the font name displayed in the
> toolbar: e.g. "Lane -Narrow" instead of "Lane - Narrow")

This part of the issue (which neither on OS X nor Linux prevents using the font) is an old one: I can reproduce it (the space getting dropped when the font name is displayed as current font in the font selector widget of the text tool controls bar) with 0.46 [1], 0.47 and all stable releases of 0.48, as well as current trunk.

-----
[1] With the official Inkscape 0.46 package for Mac OS X, the font can only applied via 'Text and Font' dialog (it fails when selecting it in the font tool controls bar font selector).

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.4, with the font linked comment #6. The font can be selected in the Text and font dialog, but is not applied.

Not reproduced with trunk revision 12149.

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
Dawn Howard (dawn-g) wrote :

I am having the same problem with this font!

Hans Peter (philip-2) wrote :

I had the same issues. As a workaround I changed the font name using Typograf
As long as there is no fix for this bug, here is the renamed font, because it is beautiful and you should be able to use it :)

Alvin Penner (apenner) wrote :

@Hans,
    just a note on the status of this bug. This bug has been marked as Fix Committed. That means that it has been fixed in a development version of Inkscape, which is currently available for testing. You can get a development version at:

https://skydrive.live.com/?cid=09706d11303fa52a&id=9706D11303FA52A%21217
or
http://www.oss-marketplace.com/index.php/downloads-mainmenu-63/Inkscape/

Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers