Filters editor jumps to the first primitive

Bug #1111459 reported by jazzynico on 2013-01-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
insaner

Bug Description

Reproduced on Windows XP, Inkscape rev. 12010 and 12079, and on kubuntu 12.04, Inkscape rev. 12073.
Not reproduced on Windows XP, Inkscape rev. 11992.

Steps:

1. Open the attached file.
2. Select the rectangle.
3. Open the Filter editor.
4. Select the Gaussian Blur effect and try to change the value.
-> The editor jumps to the Blend effect, apply a blur value depending on the mouse position, and the mouse stays with a clicked status (in the editor) .

Not reproduced when the filter is not activated.

jazzynico (jazzynico) wrote :
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.49
status: New → Triaged
tags: added: filters-svg regression ui
su_v (suv-lp) wrote :

On OS X 10.7.4 (GTK+/X11 2.24.13, GTK+/Quartz 2.24.14):
- not reproduced with r12011 and older revisions
- reproduced with r12012 and later revisions

su_v (suv-lp) wrote :

Not reproduced with r12078 after reverting the change of r12012 (fix for bug #1089406):
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12012>

Does your Windows build r12010 possibly have that patch already applied for testing?

jazzynico (jazzynico) wrote :

> Does your Windows build r12010 possibly have that patch already applied for testing?

Yes, indeed. I should always keep untouched builds only...

insaner (insaner) wrote :

(dont know how i managed to misread comment #3 when i first read it, sorry about that, suv)

hmm not sure if im doing something wrong here, but i cant reproduce on 12045, linux.. and ive been running all my builds with the patch since then and have been doing extensive filter use and never faced anything at all like you're describing..

su_v (suv-lp) wrote :

insaner wrote:
> but i cant reproduce on 12045, linux..

Also reproduced on Ubuntu 12.10 (Unity, as well as Gnome 3.6) with r12087 (local build) and on Ubuntu 12.04 (Unity) with r12072 (trunk PPA).

insaner (insaner) wrote :

ah ok.. now ive reproduced on both (clean and the one with all my patches).. strange.. ill look into it. thanks

v1nce (vincent-pennec) wrote :

While I was working with PPA 12114 I didn't notice this bug.
I just got "old" bugs I've always seen in filter editor (but didn't report until now)
https://bugs.launchpad.net/inkscape/+bug/1122495

Now I installed PPA 12131 and I got this bug + it crashes after some jumps to first primitive

v1nce (vincent-pennec) wrote :

> Not reproduced when the filter is not activated.

By the way, when you uncheck the filter it becomes unselected (and so the connexions panel is cleared) is this normal ?
Imho it should not. You may want to remove from currently selected shape (coz it's becoming too complex and your pc starts to lag) but still want to edit the filter.

v1nce (vincent-pennec) wrote :

> By the way, when you uncheck the filter it becomes unselected (and so the connexions panel is cleared) is this normal ?

tested : It's a regression, it was fine in 0.48.3

su_v (suv-lp) wrote :

v1nce wrote:
>> By the way, when you uncheck the filter it becomes unselected
>> (and so the connexions panel is cleared) is this normal ?
>
> tested : It's a regression, it was fine in 0.48.3

This is also caused by the changes in r12012 to fix bug #1089406 (tested with archived builds and current trunk with the changes from r12012 reverted).

@insaner - I'm going to revert the changes from r12012: AFAICT the unintended side-effects are affecting normal usage more than the issue they intend to fix (bug #1089406 describes a temporary display problem: the list initially shows the auto-generated unique id instead of the filter effect label after adding a new effect).

su_v (suv-lp) wrote :

Changes from r12012 reverted in revision 12137.

Changed in inkscape:
milestone: 0.49 → none
status: Triaged → Fix Released
insaner (insaner) wrote :

new patch for bug #1089406 fixes this.. please test and let me know

insaner (insaner) wrote :

i will be checking this in hopefully by friday. let me know if there are any issues

v1nce (vincent-pennec) wrote :

1:0.48+devel+12226+35~precise1 ubuntu 12.04

original bug seems fixed.
comment #9 fixed.

1122495 is not fixed.
open the attached test.
Duplicate Gaussian Blur.
Set Deviation on last Gaussian.
Return to n-1 Gaussian.
The value is the same as the one you've just set.

insaner (insaner) wrote :

hey v1nce, just to confirm, you are saying there are no issues with the (most recent) patch in regards to this bug, only that the patch doesnt fix bug #1122495 .. is that right?

v1nce (vincent-pennec) wrote :

Yes.

> there are no issues with the (most recent) patch in regards to this bug

I don't know what is the latest patch version.
I tested with 1:0.48+devel+12226+35~precise1.

When I opened 1122495 someone (JazzyNico) suggested 1122495 could be closely related to (if not a duplicate of) 1111459.
For me it looks like your patch fixes 1111459 (with no side effect as much as I can tell) but not the 1122495.

Sorry for reporting stuff about 1122495 here. It introduces confusion.

insaner (insaner) on 2013-09-16
Changed in inkscape:
assignee: nobody → insaner (insaner)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments