command-line PDF export should have predictable and controllable behavior

Bug #1110549 reported by bcrowell on 2013-01-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

In the dialog box for exporting to PDF, there are a number of options: a drop-down menu for choosing the version of PDF, plus a bunch of booleans controlled by checkboxes. Almost all of these are exposed to the command-line interface, but two are not: restrict to PDF version and rasterize filter effects. The current behavior seems to be that command-line exporting defaults to whatever was selected the last time the user went through the GUI. This is undesirable, because it means that in an automated process in which a script calls inkscape, the results silently change based on something the user did in the GUI. For my own use, I have problems with tools that have buggy support for PDF 1.5, so I want to make sure PDF 1.4 is never exported.

I think the defaults for command-line PDF export should be hardcoded and predictable, not based on the last thing the user did in the GUI. In particular, I think PDF 1.4 should always be the default for command-line export.

Regardless of whether the defaults are unlinked from the GUI, it would be very helpful to have the two missing options exposed in the command line interface like this:

--export-rasterize-filters
--export-pdf-version=VERSION

If the defaults do get unlinked from the GUI, it would be important to add the options, because otherwise people who don't like the defaults would have no way to change them.

If there is a consensus on what the behavior should be, I think I could submit a patch. (It's been a long time since I've tried to build Inkscape on my machine.)

There seem to be other users who want this: https://bugs.launchpad.net/inkscape/+bug/664335/comments/15

Related branches

description: updated
su_v (suv-lp) on 2013-01-30
tags: added: cli exporting pdf
Changed in inkscape:
importance: Undecided → Wishlist
Vinipsmaker (vinipsmaker) wrote :

For the option --export-rasterize-filters, you can use --export-ignore-filters.

For the other options, this bug is a duplicate of bug #669748.

su_v (suv-lp) wrote :

> For the other options, this bug is a duplicate of bug #669748.

The branch <lp:~schwieni/inkscape/inkscape> implements the command line options for the PDF version (proposed for merging on 2013-04-26).

su_v (suv-lp) wrote :

> The branch <lp:~schwieni/inkscape/inkscape> implements the command
> line options for the PDF version (proposed for merging on 2013-04-26).

Nevermind - the additional options already have been added to the merge proposal for bug #669748 (r12301).

Linking as duplicate to bug #669748. Please add a comment here (bug #1110549) and revert the duplicate status if you disagree.

Vinipsmaker (vinipsmaker) wrote :

> The branch <lp:~schwieni/inkscape/inkscape> implements the command line options for the PDF version (proposed for merging on 2013-04-26).

Then this means that I wasted my efforts on the wrong bug.
=(((

The code is so similar, also...

su_v (suv-lp) wrote :

> Then this means that I wasted my efforts on the wrong bug.
> =(((

Sorry for the delay in commenting about that other very recent merge proposal here in this report (I wasn't aware that you had been working on bug #669748 before the notifications of the merge proposal had been sent out).

Thorsten Glaser (mirabilos) wrote :

So, in which version was this fixed?

I absolutely need to be able to use inkscape in scripts and tell it to export PDF 1.4 because otherwise, latex (with “\RequirePackage{pdf14}”) complains when embedding these PDFs.

The inkscape manual page does not show anything related to PDF version when grepping (case-insensitively) for PDF in it:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=====================-===============-===============-===============================================
ii inkscape 0.48.4-5+b1 i386 vector-based drawing program

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

On 2014-07-16 14:25 +0100, Thorsten Glaser wrote:
> So, in which version was this fixed?

As can be seen in the bug status and milestone of the report you just unlink this one from:
- Bug #669748 “Add a command-line switch to specify EPS Export level”
  <https://bugs.launchpad.net/inkscape/+bug/669748>
the new command line options for PDF version and PostScript Language levels will be available in the next major release 0.91 (the bug status is 'Fix Committed' not 'Fix Released', and the bug's milestone is set to '0.91').

Restoring duplicate status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers