Used symbols won't show in webbrowser due missing attribute.

Bug #1107924 reported by Wolthera van Hövell tot Westerflier on 2013-01-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Martin Owens

Bug Description

I made a symbol out of a group, and then used that symbol on a few places in an svg document.
When viewing the document in a webbrowser(I tried firefox and chrome), the use elements couldn't be viewed.

I tried looking at other examples of the use-element, because, perhaps, it wasn't supported yet by those browsers. When I found examples it was obvious the browsers did support it. However, the difference between my files and the examples was that the symbols in the examples had the attribute/style 'overflow' set to 'visible'.

Doing that to my own symbols resulted in the use elements becoming visible in the webbrowser.

Maybe it's an idea to append 'overflow:visible' automatically to symbols as standard behaviour?

su_v (suv-lp) wrote :

See also <http://wiki.inkscape.org/wiki/index.php/SymbolsDialog#Bugs.2FIssues>
<quote>
- Inkscape gives the <use> element linking to a symbols a width and height of 1. This is incorrect and leads to rendering errors in other SVG renderers. Width and height (as well as x and y) should not be set unless explicitly given. This needs to be fixed. A work-around is to set overflow="visible" in a <symbol>.
</quote>

tags: added: svg symbols
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Martin Owens (doctormo) on 2013-04-21
Changed in inkscape:
assignee: nobody → Martin Owens (doctormo)
status: Confirmed → Fix Committed
Brynn (brynn4inks) wrote :

I see it says Fix Commited, but I'm having this problem with an image I uploaded to my InkSpace (on inkscape.org, using Firefox to view it) https://inkscape.org/en/gallery/item/5141/. All the symbols are missing, but if you download the SVG, you can see that the symbols are there.

Thanks :-)

su_v (suv-lp) wrote :

On 2013-04-21 03:16 (+0100), Martin Owens wrote:> ** Changed in: inkscape
> Status: Confirmed => Fix Committed

Refers to revision 12289
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12289

Setting milestone and bug status accordingly.

Changed in inkscape:
milestone: none → 0.91
status: Fix Committed → Fix Released
Brynn (brynn4inks) wrote :

Sorry, Win7, 64-bit, Inkscape 0.91 (part of the file made with 32-bit Inkscape, and part made with 64-bit Inkscape) (not sure which created the symbols, if it matters) and viewed with Firefox .

Yikes!! I was testing if the same problem happens with IE. But with IE there seems to be some other display problem with the gallery. (But the same issue with symbols does appear in IE.) Attached are 2 PNGs showing how the same image is displayed with both Firefox and IE. Should that distortion in IE be reported in the Inkscape-Web account in LP? Or maybe something on my end, with IE??

Thanks again :-)

PS - other SVGs do not show this distortion, so must be something in my file. But what? Should I make new report? TA

Brynn (brynn4inks) wrote :

Oh gosh, that was a fast reply ~suv. I didn't even see it before I posted the 2nd comment.

Unfortunately, I don't understand well enough to read between the lines what this means. Is the fix released in 0.91? Does this mean the fix doesn't work (for this file)? Or is it only fixed in a development version?

su_v (suv-lp) wrote :

@Brynn - please file a separate report and attach a test case (Inkscape SVG) there.

Brynn (brynn4inks) wrote :

Will do :-)
Wait, do you mean for the IE issue? or symbol issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers