Filter Editor doesn't remember what filter type is used after an "undo/redo" is done

Bug #1098060 reported by rickmastfan67 on 2013-01-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
insaner

Bug Description

Inkscape 0.48.4 r9939
Windows 7 x64

Steps to reproduce:
1. Draw anything (I recommend an Ellipse)
2. Filters > Shadows and Glows > Inner Shadow
3. Active the "Filter Editor" in the "Filters" menu. (Notice that the only filter there is the "Inner Shadow".)
4. Hit the Undo button.
5. Hit the Redo button.

What happens:
The redone filters name is "filter" in the "Filter Editor".

What should happen:
The name of the filter should be "Inner Shadow" like it was before the "Undo/Redo" in the "Filter Editor".

NOTE: This probably happens with all the other filters besides the "Inner Shadow", but since I saw this happening with it, that's how I'm reporting it.

rickmastfan67 (rickmastfan67) wrote :

Also, it seems that the "undo" breaks names for any other filters you want to add.

Substitute Step 5 above with this to see what I mean:
5. Filters > Shadows and Glows > Cutout Glow

What happens:
The new filter is called filter4643 (numbers part seems to be random).

What should happen:
The name of the new filter should be "Cutout Glow".

jazzynico (jazzynico) wrote :

Confirmed with Inkscape trunk revision 12011.
Fixed in revision 12012 with Bug #1089406 "filter name is random "filter232" when first added".

tags: added: filters-svg ui
Changed in inkscape:
assignee: nobody → insaner (insaner)
importance: Undecided → Low
milestone: none → 0.49
status: New → Fix Committed
su_v (suv-lp) wrote :

Changes from r12012 reverted in r12137 due to unintended side effect with basic usage of the filter editor (see bug #1111459 for details).

Changed in inkscape:
assignee: insaner (insaner) → nobody
milestone: 0.49 → none
status: Fix Committed → Triaged
insaner (insaner) wrote :

attached new patch in bug #1089406, please let me know if it fixes this issue too

insaner (insaner) wrote :

ok, revision 12232 should fix this.. if so, please assign to me and mark as fix committed.. thanks

rickmastfan67 (rickmastfan67) wrote :

~suv, can you do what insaner above requested please?

su_v (suv-lp) on 2013-09-15
Changed in inkscape:
assignee: nobody → insaner (insaner)
milestone: none → 0.49
status: Triaged → Fix Committed
rickmastfan67 (rickmastfan67) wrote :

Is this bug fixed in 0.48.5 too with the backport of the bug #1089406 fix? If so, should the milestone for this be updated from 0.49 > 0.48.5?

su_v (suv-lp) wrote :

Fixed in stable release branch in revision 10000 with the backported fix for bug #1089406.

Changed in inkscape:
milestone: 0.49 → 0.48.5
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers