node at 0,0 is un-selectable

Bug #1095288 reported by rickmastfan67 on 2013-01-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

Inkscape 0.48.4 r9939
Windows 7 x64

Steps to reproduce: (or just skip to the attachment)
1) Start a new document.
2) Go into the document preferences and set the width to 310, and the height to 226. (this step isn't necessary, but just thought it would be nice to have the same size as the attachment)
3) Select the "Draw Bezier curves" tool.
4) Start manually drawing a box to fill the entire document, starting @ 0,0. (final product will have just 4 nodes)
5) Once you have the box drawn, set the "stroke" to "none" and select a fill color.
6) Now, fine tune all 4 nodes locations in your object so that they are exactly @ each corner of the document with the "Edit paths".
7) Once all the nodes are set at exactly each corner, select the "Select" tool, and then go back to the "Edit paths" tool.

What happens:
When you look at the box you created, only 3 nodes are now shown. The 0,0 node is nowhere to be found.

What should happen:
All 4 nodes of your object should be shown in the "Edit paths" mode.

Workaround:
To be able to get to the "missing" 0,0 node, select another node and hit "TAB" till you find yourself on the 0,0 per the coordinates box displaying all 0's.

I've attached a file that will allow you to skip right to step 7 and see the end result.

If this is a duplicate, I'm sorry. I tried searching "0,0" but couldn't find a report on this subject. Just one that had to do with the missing arrows @ 0,0 for when a document touches that corner (which also happens here).

Related branches

rickmastfan67 (rickmastfan67) wrote :
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.4 on OS X 10.7.4,
not reproduced with Inkscape 0.48+devel r12006.

Likely related to (or a duplicate of)
- Bug #360158 in Inkscape: “Control points not drawn at (0,0)”
  <https://bugs.launchpad.net/inkscape/+bug/360158>
since the lower left scale arrow of the select tool is also not displayed if the lower left corner of the object's visual bbox is positioned at the page origin, and the object has no stroke.

tags: added: node-editing ui
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.49
status: New → Fix Committed
su_v (suv-lp) wrote :

Tests with archived builds confirm that the fix for bug #360158 in r10463 also addressed the issue with the missing control handle of the node positioned at 0,0 of a path without a stroke in the node tool context:

- Inkscape 0.46 renders the control handle at 0,0 as expected.
- Inkscape 0.47, 0.48.x and trunk <= r10325 don't render the control handle at 0,0 at all.
- Inkscape trunk r10330 - r11461 renders the node control handle slightly offset from the origin (below, to the right).
- Inkscape trunk >= r10463 renders the control handle correctly.

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
su_v (suv-lp) wrote :

> tags: added: backport-proposed

See <https://bugs.launchpad.net/inkscape/+bug/360158/comments/8> for details.

tags: added: backport-proposed
su_v (suv-lp) wrote :

Backport committed to lp:inkscape/0.48.x in revision 9966

Changed in inkscape:
milestone: 0.49 → 0.48.5
Kris (kris-degussem) on 2013-12-11
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments