alt + scroll to select messes up opacity

Bug #1092374 reported by insaner on 2012-12-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
insaner

Bug Description

when using the alt + scroll method to select an object, it messes up the transparency of objects.

reproduce by:

create a box with 60% transparency
create a text on top of that with 80% transparency and a different color
(create more objects on top of that if you wish)

move your mouse over the text and with alt pressed down, use your scroll wheel and watch the transparency of the box disappear (or the other objects).. but only of the display.. ie, the property itself is not affected, and even if you save it now, close and reopen, the object will now be rendered properly with the transparency you originally selected.

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r11963 on OS X 10.7.4.

See also this message in the original discussion when this new feature was committed:
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/35465/focus=35737>

Note: 'View > Duplicate Window' will also show the correct opacity values, as does hiding and showing the layer(s) of the affected object(s).

tags: added: selection
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
summary: - alt + scroll to select messes up transparency
+ alt + scroll to select messes up opacity
su_v (suv-lp) wrote :

Note: AFAICT this only affects object opacity (and not fill- or stroke-opacity aka Alpha).

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape trunk revision 12149.

Changed in inkscape:
status: Confirmed → Triaged
insaner (insaner) wrote :

of relevance, here is the original commit: http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/9976

by the way, I've been trying to see if I can fix this thing, see my post in the mailing list, hopefully someone can help me out.

insaner (insaner) on 2013-04-11
Changed in inkscape:
assignee: nobody → insaner (insaner)
insaner (insaner) wrote :

so, thanks to suv's link to that comment, i was able to track down different pieces of code, and voila: a gift for all of you.

let me know how this patch works out for you.. of note, please check that alt-scrolling while you have some other dialog or control/tool works as you expect it to.

insaner (insaner) wrote :

bug #1159899 might be a duplicate of this one

insaner (insaner) wrote :

patch #2 fixes alt+scrolling on the canvas while another window is open (say, the preferences window). this patch will actually switch the focus to the canvas window away from whatever other window you had open (while still leaving it open)

let me know if this works fine for you.

insaner (insaner) wrote :

i will be checking this code in tomorrow unless anyone has any complaints

jazzynico (jazzynico) wrote :

Just found a special case that still fails with the patch from comment #7:

1. Open the attached file.
2. Put the cursor on the rectangle, select it with Alt+scroll and keep Alt pressed. The rectangle's opacity is now 100%.
3. Move the cursor to the bottom of the circle (not the overlapping zone!), select it with Alt+scroll and keep Alt pressed. Both object now have opacity set to 100%.
4. Release the Alt key. The rectangle still have its opacity set to 100%.

su_v (suv-lp) on 2013-04-21
Changed in inkscape:
status: Triaged → In Progress
insaner (insaner) wrote :

once again, a hacky fix, hopefully its ok.. basically, if you move your mouse while in the "alt+scroll" select state, it reverts to proper opacities (though you still have the "alt" button pressed).. the other solution i can think of would require the handling of another linked list (and more memory.. ) which i dont think is really necessary.. plus, jazzynico's comment #9 is indeed a special case, who knows how often people would run into it.

anyways, let me know if the way i went about fixing it is ok.. if it is, then i can commit the changes

insaner (insaner) wrote :

ok, just after i posted that, i thought up with a slightly better solution.. try this one instead..

also, for you programmers, please check to see if this will not introduce a memory leak.. i dont know c++ or the inkscape code, or gtk enough to know if it will or not...

thanks

insaner (insaner) wrote :

so, any complaints? if not i guess i will just check these changes in by friday and mark as fix committed

jazzynico (jazzynico) wrote :

Tested successfully on Windows XP, Inkscape trunk revision 12312.

> please check to see if this will not introduce a memory leak

I'm not an expert, but the Help>About memory dialog show no increase in the memory consumption.

Thanks for the patch!

insaner (insaner) on 2013-05-02
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

> status: In Progress → Fix Committed

r12319

Changed in inkscape:
milestone: none → 0.49
su_v (suv-lp) wrote :

[*] see <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status> («bugs that only appeared in the development version, and were never encountered in a stable release.»).

Changed in inkscape:
milestone: 0.49 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments