Extension to braille not working on Xubuntu 12.10

Bug #1090865 reported by Frank Lanitz on 2012-12-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
su_v
inkscape (Ubuntu)
Low
Unassigned

Bug Description

When trying to use the extension to set an text into braille an python error is coming up:

> File "text_braille.py", line 7
> SyntaxError: Non-ASCII character '\xe2' in file text_braille.py on line 7, but no encoding declared;
> see http://www.python.org/peps/pep-0263.html for details

This seems to not only happen on Xubuntu 12.10 but also on Fedora

Related branches

nightrow (jb-benoit) wrote :

Not a problem on win7 for 0.48+devel r11943. When trying in 0.48.2, braille result is only a square box for each letter.
What inkscape version are you using ?

Frank Lanitz (frlan) wrote :

It's 0.48.3.1

su_v (suv-lp) wrote :

@nightrow - wrt to Windows, Inkscape 0.48.2 and empty square boxes, see bug #424223 (you need to explicitly choose a font which includes the braille glyphs). The newer devlibs used for current trunk builds have a bug fixed wrt to font configuration, and likely no longer expose this issue… (see also bug #1060498).

tags: added: extensions-plugins
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48.3.1 on
- OS X 10.7.4, Python 2.7.3
- Ubuntu 12.10, Python 2.7.3

Not reproduced with current trunk on either system.

Changed in inkscape:
milestone: none → 0.49
status: New → Fix Committed
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.2, Python 2.7.3 on OS X 10.7.4 either - this looks like a regression in 0.48.3.1 (as well as current 0.48.x r9938)… investigating.

su_v (suv-lp) on 2012-12-16
tags: added: backport-proposed
su_v (suv-lp) wrote :

The difference is the position of the line with the character encoding declaration: in 0.48.3.1, it got moved down to the third line because a shebang including an additional newline had been inserted (r9829). In current trunk OTOH the shebang line had been inserted without additional newline (r9734).

Attached patch fixes the extension in the stable release branch.

su_v (suv-lp) wrote :

Better batch (according to PEP263, and to match encoding declarations in other extensions scripts).

@JazzyNico - which version would you recommend?

Changed in inkscape:
importance: Undecided → Medium
milestone: 0.49 → 0.48.4
status: Fix Committed → In Progress
jazzynico (jazzynico) wrote :

@~suv - For the same reasons, I'd go for version 2.

su_v (suv-lp) wrote :

Pushed to 0.48.x in r9939,
Synced in trunk in r11958.

Changed in inkscape:
assignee: nobody → ~suv (suv-lp)
status: In Progress → Fix Committed
tags: removed: backport-proposed
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
milestone: 0.48.4 → 0.48.5

The attachment "1090865-fix-text_braille-PEP263-048x.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in inkscape (Ubuntu):
status: New → Triaged
tags: added: patch-accepted-upstream
removed: patch
Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.5-2ubuntu1

---------------
inkscape (0.48.5-2ubuntu1) utopic; urgency=medium

  * Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
    - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
    - inkscape crashed with SIGSEGV in
      sp_dtw_color_profile_event() (LP: #966441)
    - inkscape crashed with SIGSEGV (LP: #1051017)
    - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
      (LP: #1163241)
    - save a copy reverts to save as (LP: #529843)
    - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
  * Remaining changes:
    - debian/control:
      + Set Ubuntu Developer as maintainer,
      + build-depend on dh-translation to handle Ubuntu translation,
      + demote pstoedit from Recommends to Suggests (because it's in universe),
    - debian/patches/0006_add_unity_quicklist_support.patch: add.
    - debian/patches/series: update.
    - debian/rules:
      + add dh_translation to handle Ubuntu translation
  * Drop debian/patches/librevenge.patch (superseded by
      debian/patches/0006-Update_to_new_libwpg.patch)

inkscape (0.48.5-2) unstable; urgency=medium

  * debian/patches/: patchset updated
    - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
      Thanks to Rene Engelhard (rene) for the patch.
  * debian/control: build-dependencies updated
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
  * debian/: dh-autoreconf usage applied

inkscape (0.48.5-1) unstable; urgency=medium

  [ Luca Bruno ]
  * debian/rules: fix FTBFS on alpha (Closes: #738155)

  [ Mattia Rizzolo ]
  * debian/patches/: patchset updated against v0.48.5
    - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
    - 0005-Fix_FTBFS_due_to_tests.patch added

  [ Matteo F. Vescovi ]
  * Imported Upstream version 0.48.5
 -- Alex Valavanis <email address hidden> Tue, 19 Aug 2014 19:10:32 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers