Inkscape: A Vector Drawing Tool

No display in outline mode

Reported by zoqaeski on 2012-11-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

On Inkscape 0.48.3.1, switching to Outline Mode with Control-Num5 results in a blank canvas being displayed. Objects can still be selected, and edited, but there's no display of paths.

Version: 0.48.3.1
Architecture: x86_64

Steps to reproduce: Edit a moderately complex document, and switch to outline mode. No display.

zoqaeski (zoqaeski) wrote :
~suv (suv-lp) wrote :

Known issue triggered by changes in cairo >= 1.12.4:
<https://bugs.freedesktop.org/show_bug.cgi?id=56099>

Affects current stable as well as trunk.

tags: added: cairo renderer-cairo
removed: display outline-mode
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
~suv (suv-lp) wrote :

> Version: 0.48.3.1
> Architecture: x86_64

Which distro are you using?

zoqaeski (zoqaeski) wrote :

Fully up-to-date Arch Linux; Inkscape and dependencies are from repos.

~suv (suv-lp) wrote :

Testing just released cairo 1.12.8 on OS X 10.7.4 (X11 and Quartz cairo surface backends with Inkscape 0.48.3.1 and Inkscape 0.48+devel r11861):

- not fixed: outline view mode still renders invisible
  affects current stable 0.48.3.1 and trunk

- fixed (since 1.12.6): invisible auxiliary paths and handles
  ° path outlines (red/green), node handles (blue) in
    Pen, Pencil and Node tool
  ° circle (grey/green) indicating distance to guide path in
    Calligraphy tool hatch mode
  ° circle (orange) indicating brush size of Tweak tool (width)
  ° circle (orange) indicating spray area of Spray tool (width)
  ° possibly others I missed in my tests
  affected current stable (0.48.3.1)

- AFAICT fixed (since 1.12.8): rendering artifacts with stroked curves
  affected trunk [3]

~suv (suv-lp) wrote :

Fix committed
- trunk: r11862
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11862>
- stable (0.48.x): r9918
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/RELEASE_0_48_BRANCH/revision/9918>

Fix tested and confirmed on OS X 10.7.4 with cairo 1.12.8 and Inkscape 0.48.x r9918, 0.48+devel r11862.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.48.4
status: Confirmed → Fix Committed
Ted Gould (ted) on 2012-12-17
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.