LPE perspective path crashes Inkscape

Bug #1068987 reported by Kris on 2012-10-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof

Bug Description

Wathever the path is drawn, when selecting the perspective path LPE for applying on the path, Inkscape crashes.
No detailed debug information or console messages available.

Vista 64 bit, r11813.

su_v (suv-lp) wrote :

Duplicate of bug #280431 “System freezes on Perspective Path Effect“?

tags: added: crash livepatheffects
su_v (suv-lp) wrote :

Note that this path effect is not enable with default builds (it's among the experimental LPEs which are disabled because they are not stable).

su_v (suv-lp) wrote :

Attaching backtrace with Inkscape 0.48+devel r11809 on OS X 10.7.4

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Unsetting bug importance (I'm not sure whether importance should be high for effects which are intentionally disabled with default builds).

Changed in inkscape:
importance: Low → Undecided
su_v (suv-lp) wrote :

> Note that this path effect is not enable with default builds (it's among the
> experimental LPEs which are disabled because they are not stable).

Seems that in trunk, the experimental LPEs are currently enabled by default for Windows builds (unlike on linux/osx):
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11203>

Alvin Penner (apenner) wrote :

yes, on Windows, these appear to be enabled by default, backtrace attached

Johan Engelen (johanengelen) wrote :

I've just now disabled experimental LPEs in trunk because we are in frost now.

su_v (suv-lp) wrote :

Bug #280431 “System freezes on Perspective Path Effect“ has been marked as duplicate of this one (which has more recent backtraces attached).

su_v (suv-lp) wrote :

jabiertxof on irc noted that the crash occurs if no perspective object is defined in the current document (created by the 3dbox tool) - confirmed with 0.48+devel r12670 (with experimental LPE enabled).

Jabiertxof (jabiertxof) on 2013-10-12
Changed in inkscape:
assignee: nobody → Jabiertxo Arraiza Cenoz (jabiertxof)
Jabiertxof (jabiertxof) wrote :

I attach a diff who make some improvements to the LPE:
1. Alert if no perspective element in defs
2. Add a button to refresh the perspective if changed by editing his 3dBOX
3. Add a text box to input the ID of the perspective to use, default first perspective

jazzynico (jazzynico) on 2013-10-15
Changed in inkscape:
status: Confirmed → In Progress
su_v (suv-lp) on 2013-10-17
Changed in inkscape:
importance: Undecided → Medium
ScislaC (scislac) wrote :

The patch mitigates the problem by A) not crashing and B) getting the user's attention as to why it won't work yet.

Jabiertxof (jabiertxof) wrote :

Here the patch ready to apply to current trunk.
Changed gtkmm sub-headers to main and also improve the perspective id widget.

I need better "Grammar" for this strings:
You need a BOX 3D object
First perspective selected
First perspective
Set the perspective ID to apply
Refresh perspective

Jabiertxof (jabiertxof) on 2014-08-20
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) on 2014-08-20
Changed in inkscape:
milestone: none → 0.91
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers