Have GtkSpell use Enchant for spell checking

Bug #1049548 reported by Pander on 2012-09-12
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

I would like to request that Inkscape will use GtkSpell in such a way that it will use Enchant for spell checking. Enchant is a spell checking wrapper using the spell checker installed on the system. This can be Aspell, Ispell, Myspell, Hunspell and much more.

According to https://bugs.launchpad.net/inkscape/+bug/171111/comments/8 and the package dependencies on Ubuntu, it is clear that Aspell is begin used. However, most people are using superior spell checker Hunspell and want to use this also in Inkscape. Spelling dictionaries for Dutch and many other languages are nowadays only released for Hunspell.

The changes to the implementation will be minimal, see http://gtkspell.sourceforge.net/ on how to use Enchant. See also gedit, firefox and many other major applications which use Enchant.

Benefits of fixing this bug are:
- freedom of choice in spell checker to use (mainly ability to use Hunspell)
- identical spell checking as other applications on the system, also in terms of available dictionaries and personal dictionaries
- dependencies on aspell and aspell-en can be dropped

su_v (suv-lp) on 2012-09-12
Changed in inkscape:
importance: Undecided → Wishlist
Pander (pander) wrote :

As far as I, the reporter, am concerned: importance for this bug can go from Wishlist to Medium.

vgeloven (vgeloven) on 2012-11-19
Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) on 2013-02-25
Changed in inkscape:
status: Confirmed → Triaged
Pander (pander) wrote :

When can a fix be expected?

ScislaC (scislac) wrote :

This is a wishlist item, not a bug. Given that I'm not aware of anyone currently working on implementing this request, we do not have any timeframe on it.

Pander (pander) wrote :
Pander (pander) wrote :

Ah, after looking at the source code and package dependencies I found that the build scripts require GtkSpell 3.0 or GtkSpell 2.0 but the Ubuntu package depends on GtkSpell 2.0. From the site of GtkSpell I read that between 2.0 and 3.0 the API has changed. Perhaps this is the reason that it doesn't work an other problems arise, such as not finding Hunspell behind Enchant.

Pander (pander) wrote :

Inkscape explicitly requires aspell at the moment, which is outdated compared to hunspell. Enchant is good to use to provide legacy support. Installation of Enchant offer the user to install hunspell and/or aspell and/or other spelling checkers. The package for Debian/Ubuntu says

Depends: python:any (>= 2.7.5-5~), libaspell15 (>= 0.60.7~20110707), libatkmm-1.6-1v5 (>= 2.24.0), libc6 (>= 2.14), libcairo2 (>= 1.12.0), libcairomm-1.0-1v5 (>= 1.12.0), libcdr-0.1-1, libdbus-glib-1-2 (>= 0.88), libfontconfig1 (>= 2.11.94), libfreetype6 (>= 2.2.1), libgc1c2 (>= 1:7.2d), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1), libglibmm-2.4-1v5 (>= 2.50.0), libgomp1 (>= 4.9), libgsl2, libgtk2.0-0 (>= 2.24.0), libgtkmm-2.4-1v5 (>= 1:2.24.0), libgtkspell0 (>= 2.0.10), libjpeg8 (>= 8c), liblcms2-2 (>= 2.2+git20110628), libmagick++-6.q16-7 (>= 8:6.9.6.8), libpango-1.0-0 (>= 1.37.2), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libpangomm-1.4-1v5 (>= 2.40.0), libpng16-16 (>= 1.6.2-1), libpoppler-glib8 (>= 0.18.0), libpoppler64 (>= 0.48.0), libpopt0 (>= 1.14), libpotrace0, librevenge-0.0-0, libsigc++-2.0-0v5 (>= 2.8.0), libstdc++6 (>= 5.2), libvisio-0.1-1, libwpg-0.3-3, libx11-6, libxml2 (>= 2.7.4), libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.1.4)
Recommends: aspell, imagemagick, libimage-magick-perl, libwmf-bin, python-lxml, python-numpy, python-scour, transfig

This needs to change to:

Depends: python:any (>= 2.7.5-5~), libenchant1c2a, libatkmm-1.6-1v5 (>= 2.24.0), libc6 (>= 2.14), libcairo2 (>= 1.12.0), libcairomm-1.0-1v5 (>= 1.12.0), libcdr-0.1-1, libdbus-glib-1-2 (>= 0.88), libfontconfig1 (>= 2.11.94), libfreetype6 (>= 2.2.1), libgc1c2 (>= 1:7.2d), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1), libglibmm-2.4-1v5 (>= 2.50.0), libgomp1 (>= 4.9), libgsl2, libgtk2.0-0 (>= 2.24.0), libgtkmm-2.4-1v5 (>= 1:2.24.0), libgtkspell0 (>= 2.0.10), libjpeg8 (>= 8c), liblcms2-2 (>= 2.2+git20110628), libmagick++-6.q16-7 (>= 8:6.9.6.8), libpango-1.0-0 (>= 1.37.2), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libpangomm-1.4-1v5 (>= 2.40.0), libpng16-16 (>= 1.6.2-1), libpoppler-glib8 (>= 0.18.0), libpoppler64 (>= 0.48.0), libpopt0 (>= 1.14), libpotrace0, librevenge-0.0-0, libsigc++-2.0-0v5 (>= 2.8.0), libstdc++6 (>= 5.2), libvisio-0.1-1, libwpg-0.3-3, libx11-6, libxml2 (>= 2.7.4), libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.1.4)
Recommends: imagemagick, libimage-magick-perl, libwmf-bin, python-lxml, python-numpy, python-scour, transfig

(changed libaspell15 (>= 0.60.7~20110707) into libenchant1c2a for Depends and removed aspell from Recommends)

Patrick Storz (ede123) wrote :

Inkscape still uses Aspell if you use "Text -> Check Spelling..." so we can't simply drop that dependency.

That being said we also use gtkspell (which makes use of the enchant backend) in the "Text and Font..." dialog's "Text" tab.

If we could get rid of Aspell and depend on enchant exclusively that certainly would be preferable, but it's not just a matter of changing dependencies but would require some code changes.

Pander (pander) wrote :

Understood. Hope this bug report will have exactly that affect, use only Enchant.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers