Problem with exported PDFs in acroread

Bug #1027967 reported by Alex Valavanis on 2012-07-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
inkscape (Debian)
Confirmed
Unknown

Bug Description

Forwarded from Debian

From: Falk Hueffner <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: Problem with exported PDFs in acroread
Date: Sun, 15 Jul 2012 12:09:43 +0200
Package: inkscape
Version: 0.48.3.1-1.1
Severity: normal

Unfortunately, this is somewhat involved to reproduce.

open inkscape, draw anything in fig1.svg and fig2.svg (I attach two
samples)

inkscape fig1.svg --export-pdf=fig1.pdf --export-area-drawing

inkscape fig2.svg --export-pdf=fig2.pdf --export-area-drawing

cat > figs.tex << EOF
\documentclass{article}
\usepackage{graphicx}
\begin{document}
  \includegraphics{fig1}
  \newpage
  \includegraphics{fig1}
  \includegraphics{fig2}
\end{document}
EOF

pdflatex figs.tex

acroread figs.pdf

gives "There was an error opening this document. The file is damaged
and could not ne repaired."

There is no error with PDFs not produced by inkscape.

Unfortunately, evince or xpdf do not show an error, so it might be
hard to track this down.

-- System Information:
Debian Release: sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages inkscape depends on:
ii gconf-service 3.2.5-1
ii libaspell15 0.60.7~20110707-1
ii libatk1.0-0 2.4.0-2
ii libatkmm-1.6-1 2.22.6-1
ii libc6 2.13-34
ii libcairo2 1.12.2-2
ii libcairomm-1.0-1 1.10.0-1
ii libfontconfig1 2.9.0-6
ii libfreetype6 2.4.9-1
ii libgc1c2 1:7.1-9
ii libgcc1 1:4.7.1-5
ii libgconf-2-4 3.2.5-1
ii libgdk-pixbuf2.0-0 2.26.1-1
ii libglib2.0-0 2.32.3-1
ii libglibmm-2.4-1c2a 2.32.0-1
ii libgnomevfs2-0 1:2.24.4-1
ii libgomp1 4.7.1-5
ii libgsl0ldbl 1.15+dfsg-1
ii libgtk2.0-0 2.24.10-1
ii libgtkmm-2.4-1c2a 1:2.24.2-1
ii libgtkspell0 2.0.16-1
ii liblcms1 1.19.dfsg-1.1
ii libmagick++5 8:6.7.7.10-2
ii libmagickcore5 8:6.7.7.10-2
ii libpango1.0-0 1.30.0-1
ii libpangomm-1.4-1 2.28.4-1
ii libpng12-0 1.2.49-2
ii libpoppler-glib8 0.18.4-3
ii libpoppler19 0.18.4-3
ii libpopt0 1.16-7
ii libsigc++-2.0-0c2a 2.2.10-0.2
ii libstdc++6 4.7.1-5
ii libwpd-0.9-9 0.9.4-3
ii libwpg-0.2-2 0.2.1-1
ii libx11-6 2:1.5.0-1
ii libxml2 2.8.0+dfsg1-4
ii libxslt1.1 1.1.26-13
ii zlib1g 1:1.2.7.dfsg-13

Versions of packages inkscape recommends:
ii aspell 0.60.7~20110707-1
ii imagemagick 8:6.7.7.10-2
ii libwmf-bin 0.2.8.4-10
ii perlmagick 8:6.7.7.10-2
ii pstoedit 3.60-2+b1

Versions of packages inkscape suggests:
pn dia | dia-gnome <none>
ii libgnomevfs2-extra 1:2.24.4-1
pn libsvg-perl <none>
pn libxml-xql-perl <none>
ii python 2.7.3-1
ii python-lxml 2.3.2-1
ii python-numpy 1:1.6.2-1
pn python-uniconvertor <none>
pn ruby <none>
pn skencil <none>

-- no debconf information

Changed in inkscape (Debian):
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.