GTK3: crash when deleting a stacked path effect in the path effect editor

Bug #1013141 reported by su_v on 2012-06-14
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

Inkscape built and running with GTK3 crashes when removing one of two or more stacked path effects in the Path Effects editor.

Sample steps to reproduce:
1) launch inkscape (new default preferences)
2) switch to the pencil tool
3) change mode to 'Spiro splines'
4) change shape to e.g. 'Ellipse'
5) scribble a path
6) open 'Path > Path Effects…'
7) delete the 'Spiro spline' path effect

--> crash:
Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x00000000000000d0
0x000000010069cc6c in LivePathEffectObject::get_lpe (this=0x0) at lpeobject.h:44
44 Inkscape::LivePathEffect::Effect * get_lpe() { return lpe; };

Tested with Inkscape 0.48+devel r11497 on OS X 10.7.4
glib 2.32.2, gtk3/x11 3.4.2, gtkmm 3.4.0

Not reproduced with Inkscape 0.48+devel r11497 built and running with GTK2.

su_v (suv-lp) wrote :
tags: added: livepatheffects
ScislaC (scislac) on 2012-06-14
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

We need to figure out where the Glib warnings are coming from:

GLib-GObject-WARNING **: value "-inf" of type `gdouble' is invalid or out of range for property `lower' of type `gdouble'

We can trap the cause of these by setting "br g_logv" in gdb before running the program. Unfortunately, it freezes my Xserver. I'll try attaching to the process using a terminal emulator at some point. If anyone gets there first, a backtrace would be very useful!

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

> Unfortunately, it freezes my Xserver.

Maybe this tip helps:
<http://developer.gnome.org/gtk-faq/stable/x461.html>

Alex Valavanis (valavanisalex) wrote :

Great! Thanks for the advice :-)

su_v (suv-lp) wrote :

Another backtrace, this time with debug symbols for glib 2.32.3 available.

(still working on creating & keeping them for GTK3 as well - MacPorts doesn't offer them as packages ;-) )

su_v (suv-lp) wrote :

Attaching backtrace 2 (r11499) with debug symbols for GTK3 available …

>> Unfortunately, it freezes my Xserver.

If GTK3 was compiled with '--enable-debug=yes', possibly setting GDK_DEBUG=nograbs is another workaround to prevent freezing of the X server (or using the command line option '--gdk-debug nograbs'). According to Google this might cause some parts of the GUI to act strangely ;)

See also:
<http://developer.gnome.org/gtk3/3.4/gtk-running.html#GDK-Debug-Options>

Alex Valavanis (valavanisalex) wrote :

The bounds checking on SpinButtons appears to be stricter in GTK+ 3. I've changed the default bounds for scalar parameters from Geom::infinity to G_MAXDOUBLE (the limit for SpinButtons) in lp:inkscape r11794, which gets rid of the Glib warnings. However, it doesn't fix the crash.

tags: added: gtk3
removed: gtk3-regression
Beluga (buovjaga) wrote :

Still crashing.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.92pre1 15073 (GTK3)

jazzynico (jazzynico) wrote :

Also reproduced on Xubuntu 16.04, lp:inkscape rev. 15196.

Changed in inkscape:
status: Confirmed → Triaged
milestone: none → 0.93
Jabiertxof (jabiertxof) wrote :

This patch fix it.

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
jazzynico (jazzynico) on 2016-11-02
Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Patch tested successfully on Xubuntu 16.04.
Thanks!

Jabiertxof (jabiertxof) wrote :

commited on r.15200
Thanks jazzynico for test!

Changed in inkscape:
status: In Progress → Fix Released
jazzynico (jazzynico) on 2017-01-09
Changed in inkscape:
milestone: 0.93 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers