Build fails on Ubuntu Lucid with gtk 2.20.1 (> r11420)

Bug #1009010 reported by su_v on 2012-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Jon A. Cruz

Bug Description

As reported on irc by pippijn (and logged for cafuego's PPA), current trunk fails to build on Lucid with Gtk 2.20.1:

|14:07| < pippijn> there are exactly 2 problems
|14:07| < pippijn> one is src/widgets/desktop-widget.cpp with GSEAL
|14:08| < pippijn> and one is src/measure-context.cpp with GDK_KEY_Shift_L and R

1) introduced in 11421/11422 [1]:
  CXX widgets/desktop-widget.o
widgets/desktop-widget.cpp: In member function 'bool SPDesktopWidget::shutdown()':
widgets/desktop-widget.cpp:968: error: 'struct _GtkMessageDialog' has no member named 'label'
widgets/desktop-widget.cpp:1031: error: 'struct _GtkMessageDialog' has no member named 'label'
make[4]: *** [widgets/desktop-widget.o] Error 1

2) was probably introduced in r11459 (missing include of 'src/compat-key-syms.h' ?)

[1] <https://launchpadlibrarian.net/106243678/buildlog_ubuntu-lucid-amd64.inkscape_0.49~devel%2B11422%2B7~lucid1_FAILEDTOBUILD.txt.gz>

su_v (suv-lp) wrote :

Issue 2 (in src/measure-context.cpp with GDK_KEY_Shift_L and R) was addressed in r11463:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11463>

Alex Valavanis (valavanisalex) wrote :

Issue 1 was introduced in r11421 when I fixed the GSEAL issues in desktop widget [1]. The problem is that the gtk_message_dialog_get_message_area function was only introduced in gtk+ 2.22, which isn't available in Ubuntu Lucid.

The only real solutions, as far as I can see are...

1. Just get rid of this bit of code in Lucid. This will mean that the label in the dialog can gain focus (bug #168809) in Lucid... a minor issue.

2. Disable GSEAL_ENABLE for Lucid. Probably not an ideal solution!

[1] http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11421

Changed in inkscape:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Jon A. Cruz (jon-joncruz)
status: Confirmed → In Progress
Jon A. Cruz (jon-joncruz) wrote :

Went with solution #1 in revision #11464

Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

Changing status to 'Fix Released' in accordance to [1] - the reported issue never occurred in a released version, only in current trunk. Please revert the bug status to 'Fix Committed' if you don't agree.

[1] <http://wiki.inkscape.org/wiki/index.php/Bug_management>

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers