new glib (2.32+) patch

Bug #1008101 reported by David Bařina on 2012-06-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

When using inkscape with newer glib version, following error is occured during compilation: Only <glib.h> can be included directly.

David Bařina (dabler) wrote :
su_v (suv-lp) wrote :

Which version of Inkscape are you trying to build (and/or patch)?

Note: the latest stable sources (0.48.3.1) as well as current trunk build against glib 2.32 without needing any patches.

Duplicate of Bug #898538 “inkscape fails to build with glib 2.31”?
<https://bugs.launchpad.net/inkscape/+bug/898538>

Changed in inkscape:
status: New → Incomplete
tags: added: build
su_v (suv-lp) wrote :

Since no feedback was provided with regard to which Inkscape version the patch was intended to be applied to, I'm assuming it refers to outdated Inkscape 0.47 (based on the other reports with patches by the same reporter).

1) There are no plans to backport any fixes to the outdated release branch of Inkscape 0.47, nor to provide bug-fix releases of 0.47.
2) With regard to current sources: Inkscape 0.48.3.1 (stable) and Inkscape 0.48+devel >= r10762 (trunk) already build with latest glib versions

-> linking this report as duplicate to bug #898538.

Please add a comment here and revert the duplicate status if you don't agree and think these are different issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers