Mesh Tool: crash in GrDrag::setSelected ()

Bug #1004191 reported by su_v on 2012-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Inkscape 0.48+devel r11410 on OS X 10.7.4 (64bit), default (new) preferences:

Steps to reproduce:
1) open new document
2) draw rectangle
3) switch to the mesh tool and apply mesh gradient
4) select one of the gradient mesh corners
   (Note: status bar message is broken)
4) switch to the select tool & deselect rectangle
5) draw another rectangle

-> crash when activating the rectangle tool.

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

full backtrace with debug build (-g -O0)
(llvm-gcc-4.2, OS X 10.7.4)

ScislaC (scislac) on 2012-05-24
Changed in inkscape:
status: New → Confirmed
importance: Undecided → High
Johan Engelen (johanengelen) wrote :

does rev. 11411 fix it?

On 24-5-2012 23:44, ~suv wrote:
> full backtrace with debug build (-g -O0)
> (llvm-gcc-4.2, OS X 10.7.4)
>
> ** Attachment added: "1004191-bt-full-r11410-64bit-osx.txt"
> https://bugs.launchpad.net/inkscape/+bug/1004191/+attachment/3161784/+files/1004191-bt-full-r11410-64bit-osx.txt

These backtraces are awesome ~suv! They allow me to fix these things
within minutes.

Keep'em coming!

su_v (suv-lp) wrote :

> does rev. 11411 fix it?

AFAICT yes - many thanks for the quick fix :)

Any idea about the warnings / slightly "broken" status bar messages if a single gradient mesh corner is selected in the mesh tool context? Should I file a separate report about this?

With Apple's llvm-gcc-4.2 (64bit, OS X 10.7.4), I get lots of these warnings:
(inkscape:17537): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1 char 71: Invalid UTF-8 encoded text in name - not valid 'UH\x89\xe5H\x8d=\x8b1 selected out of 46 mesh handles on 1 selected object'

With Apple's GCC 4.2.1 (32bit, on OS X 10.5.8), I don't see any warnings to the console, but the message in the status bar seems to have some odd text at the beginning.

With FSF GCC 4.6.3 (64bit, OS X 10.7.4), again no warnings, and the message in the status bar is broken too (but differently).

su_v (suv-lp) wrote :

@Johan - I'll file the issue about the status bar message separately, closing this report as 'Fix released'.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers