Crash if default template has grid defined (r11370)

Bug #1001724 reported by su_v on 2012-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Alex Valavanis

Bug Description

Regression AFAICT introduced in revision 11370:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11370>

Steps to reproduce:
1) add a custom default template with a grid defined (it doesn't matter whether the grid is visible or not)
2) start inkscape, draw a rectangle, enable the grid (menu 'View > Grid'), save and quit
3) launch inkscape without file (opens new document based on custom default template)
4) open the file saved in step 2 from within Inkscape

-> crash

Reproduced with revision >= 11370 on Mac OS X 10.5.8 (32bit) and OS X 10.7.4 (64bit).

Sample files attached:
- 'default.svg' (based on shared default template, save as "$HOME/.config/inkscape/templates/default.svg")
- 'drawing-3.svg' (sample drawing with a rectangle, and with visible grid)

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :
su_v (suv-lp) wrote :
Alex Valavanis (valavanisalex) wrote :

Oh no... looks like I've broken things by messing around with the destroy/dispose handling :-(

There's a chance that this will be fixed after the entire SPCanvasItem tree is changed to GObject... or maybe it would be better to revert the changes and do this work in an experimental branch.

Changed in inkscape:
importance: Undecided → High
status: New → Triaged
ScislaC (scislac) wrote :

You can revert the changes and work via patches in a bug report (unless you'd prefer a branch). Just a thought.

Alex Valavanis (valavanisalex) wrote :

OK, I have reverted r11370 in lp:inkscape r11386. This seems to fix the bug for me. Because changing SPCanvasItem and its subclasses to GObject will be a fairly intrusive process (and will no doubt involve a lot of fiddling!), I think it'll be easier to work in a branch over a few days rather than to keep track of numerous iterations of patches.

Maybe I'll work on some easier/safer bits first!

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
status: Triaged → Fix Released
su_v (suv-lp) wrote :

Alex Valavanis wrote
>There's a chance that this will be fixed after the entire SPCanvasItem tree
> is changed to GObject... or maybe it would be better to revert the changes
> and do this work in an experimental branch.

Apologies if my report was filed hastily - it took me some time to figure out what exactly triggered these kind of crashes, and then I decided to report it without waiting for possible follow-up commits (to not risk having this regression slip in unnoticed).

> I have reverted r11370 in lp:inkscape r11386. This seems to fix the bug for me.

Confirmed on Mac OS X 10.5.8 (32bit) and OS X 10.7.4 (64bit).

Many thanks for your quick response (I'm glad I don't have to quit using my preferred template with trunk builds :-) ).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers