Forum for inkscape.org

Bug #1458407 reported by Hachmann on 2015-05-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape-website
Wishlist
Unassigned

Bug Description

This feature was requested on the mailing list by Brynn and Bryce.

Mark Schafer gave some info about possible options:

"I asked some Django friends and they indicated these two forum projects
seem like they might make the distance.
- http://misago-project.org/
- http://spirit-project.com/

Misago seems quite full featured. Here' s a post on adding IRC
announcements for example
- http://misago-project.org/thread/irc-bot-integration-369/#post-1144
Misago 0.5 was (in their view) be feature complete. Currently on 0.5.5
(needs postgresql)"

Integration with our user login/profile and with IRC were requested.

Bryce Harrington (bryce) wrote :

Forums issues were raised at the Board meeting yesterday:

https://inkscape.org/en/gallery/item/9563/view/

The existing Inkscape Forums site (run by a third party) is afflicted by spam and seems not as actively maintained as it once was. The board decided to 1) make an attempt to contact the site owner, and if the site is defunct to try and get a dump of the database, and 2) form a committee to look into potentially establishing our own Inkscape project maintained forum. The committee would have the duty of analyzing/selecting forum software, and so forth, including trading between options that integrate well with the site vs. ones that might be more featureful or popular. (I will post more details on how to contact and/or join the committee once it's set up.)

Hachmann (marenhachmann) wrote :

@Bryce: I've read the log, but didn't understand from it that this was the purpose of the committee. Thank you for posting the update to the situation here. I will relate this to the forum people.

Pétery Tamás (lazur) wrote :

@ is afflicted by spam
@ not as actively maintained as it once was

For the note the forum in question NEVER was maintained as much as these days by any moderator ever, based on logged moderator actions. Spam is deleted on a daily basis (now there are 50-60+ of them a day).
It's just that now there is no real protection set up against spam and moderators face a non-reasonable amount of work maintaining the level, that could be cut short if the admin of the site took the slightest action.
Which we are all been waiting for 6 months.

"...seems not as actively maintained as it once was." Actually, for the record, the forum is being maintained as much as possible from a moderator position by Lazur. And he is putting in twice as much time as necessary, because the admin doesn't have time to set in place a couple of simple things -- I expect there must be spam mods that he could install, and it's also possible to have a first message approval system (because IF used to have one) -- that would cut the workload by probably 80 to 90%.

The problem is that Lazur can't be expected to continue doing this alone, indefinitely.

And imo, the Inkscape community deserves a forum with an interested and involved admin.

I appreciate that the board has taken some interest. But here's the problem....it's a 2-part problem.

1 - This situation (at IF) has been tolerated for far too long already. I suspect Lazur is ready to walk away. And unless we can have a solution within a couple of week's time, I am too.

2 - Creating a new official forum is not something that should be rushed into. It would not benefit the community to rush into a solution. I agree that forming a committee, and carefully choosing the right kind of software, that is compatible with the website, and satisfies everyone, IS the right way to go. And I'm perfectly willing to be a part of that process. But it's not going to fix the immediate problem.

I am NOT willing to wait a month for Courtney Not to answer Another message. Because we've all made multiple attempts over the last 6 months, without success, I think it's time to abandon IF. If someone can get a server or database dump later, then that would be great.

So this is my 2-week notice for answering messages at InkscapeForum. Of course I will continue to maintain Inkscape Community, at least until this new official forum is up and running (for anyone else who has reached the end of their patience). And of course, I will make the IC database (tiny as it is, compare to IF) available for the new official forum.

If someone can teach me how, I would even be happy to merge both the databases into the new forum. But after 2 weeks, I won't be answering messages at IF anymore.

All best :-)

Hachmann (marenhachmann) wrote :

I'm still hoping that someone with a good oral command of English would try the phone number given in the whois record... It's probably not working anymore, but still...

Hachmann (marenhachmann) wrote :

Update: From the django forums, Martin and Brynn would favour Spirit. But there's a lot going on at the moment, we'll see if this is needed at all.

Hachmann (marenhachmann) on 2016-09-10
tags: added: forum webserver

I stumbled on this report while looking for another. So I thought I would post a short update.

Just a couple of weeks after the committee started work, Courtney answered a last ditch message to contact him. We've been in contact with him more, and he has agreed for IF to be community managed. Once the forum is moved to a server of the Inkscape project, he no longer wants to be involved in the forum.

However, we've been stuck for some months now, waiting for OSUOSL to make a decision about hosting a forum. There is some indication that they will, because they mentioned wanting to change the way they administer all the project's projects. But time keeps ticking by, with no further contact from them, and personally I'm having doubts that anything will happen. But others seem content to wait. So we wait :-)

I guess we can close this now, right?

I won't close it, just in case I don't understand something. But the new forum seems to be going strong!

Hachmann (marenhachmann) on 2019-12-11
Changed in inkscape-web:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers