[0.91 Tutorial Review] issues with "Advanced" tutorial

Bug #1315457 reported by Ryan Lerch on 2014-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
Inkscape-docs
High
Ryan Lerch
Inkscape-website
Medium
Unassigned

Bug Description

During the review[1] for the 0.91 release, the following issues were identified for the Advanced tutorial:

* this section on nodes doesnt mention auto-smooth. (do we want to add it here?)
"""
A node can be made cusp (Shift+C), which means its two handles can move independently at any angle to each other; smooth (Shift+S), which means its handles are always on the same straight line (collinear); and symmetric (Shift+Y), which is the same as smooth, but the handles also have the same length. When you switch the type of node, you can preserve the position of one of the two handles by hovering your mouse over it, so that only the other handle is rotated/scaled to match.
"""

* sometimes Click is capitalized, sometimes not. To be consistent with the other tutorials, it should not be capitalized.

[1] - http://wiki.inkscape.org/wiki/index.php/0.91-tutorial-review

Related branches

Ryan Lerch (ryanlerch) on 2014-05-02
Changed in inkscape-docs:
status: New → In Progress
assignee: nobody → Ryan Lerch (ryanlerch)
tags: added: documentation tutorials
jazzynico (jazzynico) on 2014-05-02
Changed in inkscape:
status: New → Triaged
Changed in inkscape-web:
status: New → Triaged
importance: Undecided → Medium
Changed in inkscape-docs:
importance: Undecided → High
Changed in inkscape:
importance: Undecided → Medium
assignee: nobody → jazzynico (jazzynico)
Bryce Harrington (bryce) on 2014-05-05
Changed in inkscape:
milestone: none → 0.91
jazzynico (jazzynico) wrote :

All proposed changes committed in Inkscape-docs, revision 496.

Changed in inkscape-docs:
status: In Progress → Fix Released
Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

SVG files NOT committed for now, due to an offset regression (see attachment). It reminds me of an old bug (Bug #817907 "Linked offsets regression") I had with the Shapes tutorials almost 3 years ago...

jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :

Offset issue fixed in inkscape-docs, revision 500.

Generated SVG files commited in the trunk, revision 13341.

Changed in inkscape:
status: In Progress → Fix Committed
Hachmann (marenhachmann) wrote :

Marking this as Fix Released now, as a discussion led to a permanent solution for updating documentation on the live website.

Changed in inkscape-web:
status: Triaged → Fix Released
jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
jazzynico (jazzynico) on 2015-08-10
Changed in inkscape-docs:
milestone: none → 0.91
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers