Inkscape crash in File>Open

Bug #1069806 reported by jazzynico on 2012-10-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
jazzynico
Inkscape Devlibs
High
jazzynico

Bug Description

Reproduced on Windows XP, Inkscape r11818, devlibs r36.
Not reproduced with Inkscape r11804, devlibs r35.

Steps:

1. Modify the preferences to use the GTK Open/Save dialog (Edit>Preferences>Interface>Windows>Desktop integration)
2. File>Open, File>Import or File>Save As.
3. Select one file
4a. Select a different file.
4b. Click on Open.

Crash with no error message.

Doesn't crash when run with gdb...
Doesn't crash when using File>Recent or drag&dropping to the canvas.

jazzynico (jazzynico) wrote :

Very likely a library or compiler issue introduced in the recent devlibs update.
Tests in progress.

Changed in inkscape-devlibs:
assignee: nobody → JazzyNico (jazzynico)
importance: Undecided → High
tags: added: crash regression win32
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
importance: Undecided → High
milestone: none → 0.49
tags: added: importing
jazzynico (jazzynico) wrote :

Still crashes with libs compiled with TDM-GCC 4.6.1 (instead of 4.4).

jazzynico (jazzynico) wrote :

The crash is apparently due to glibmm. Using r35 + glibmm-2.28.2 lead to the same issue.

jazzynico (jazzynico) wrote :

A bit less critical than I first thought: it only affects the gtk Open/Import dialog, not the native one...

description: updated
tags: added: ui
removed: importing
jazzynico (jazzynico) wrote :

Arghh! Unfortunately there's another crash when using File>Save with a new document that affects both dialogs.
Uncommitting the devlibs to r35.

jazzynico (jazzynico) wrote :

Note that the saving issue is not due to the UI, but also crashes when saving directly with the save icon.

jazzynico (jazzynico) wrote :

Apparently, the Save crash is not due to the devlibs, but is a recent regression in the Inkscape trunk.
See Bug #1070903 'Crash when saving a new document'
<https://bugs.launchpad.net/inkscape/+bug/1070903>

jazzynico (jazzynico) wrote :

Narrowing down the issue: only affects the GTK dialog with preview checked.

jazzynico (jazzynico) wrote :

The bug seems to be due to mixed C/C++ code in src/ui/dialog/filedialogimpl-gtkmm.cpp.

I've managed to fix it on Windows by C++ification of parts of the preview code.
The attached patch has been tested successfully on Windows XP, Inkscape trunk revision 11818, devlibs-testing r36, but needs to be tested on GNU/Linux and OS-X systems.

Changed in inkscape:
status: New → In Progress
jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :

Closing invalid in devlibs. Too sad I did that damned (and very probably unnecessary) uncommit too soon...

Changed in inkscape-devlibs:
status: New → Invalid
jazzynico (jazzynico) wrote :

Looks good on Ubuntu 11.04, Inkscape trunk revision 11854.

su_v (suv-lp) wrote :

> Looks good on Ubuntu 11.04, Inkscape trunk revision 11854.

On OS X 10.7.4, with GTK+/X11 2.24.13 and GTK+/Quartz 2.24.13 (both gtkmm 2.24.2), the empty preview area overlaps the file type selector - independent of the theme used.

su_v (suv-lp) wrote :

Without patch.

jazzynico (jazzynico) wrote :

Patch #2. Should now work as expected.

su_v (suv-lp) wrote :

> Patch #2. Should now work as expected.

Confirmed on OS X 10.7.4 (GTK+ 2.24.13, gtkmm 2.24.2)

jazzynico (jazzynico) wrote :

Patch committed revision 11856.

Needs to be backported to 0.48.X if we plan to release it with the new devlibs.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

No need to update 0.48.X. The option to use GTK dialogs on Windows has been added in the trunk for 0.49...

jazzynico (jazzynico) on 2015-02-14
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers