[Clock] Theme rendering bug in Natty

Bug #717987 reported by Märt Põder
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Individual Screenlets
Fix Released
Medium
Unassigned
indiv-screenlets (Ubuntu)
Fix Released
Medium
Julien Lavergne

Bug Description

PythonArgs: ['/usr/share/screenlets/screenlets-pack-all/Clock/ClockScreenlet.py']
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/pymodules/python2.7/screenlets/__init__.py", line 2074, in realize_event
     self.on_realize()
   File "/usr/share/screenlets/screenlets-pack-all/Clock/ClockScreenlet.py", line 221, in on_realize
     self.refresh_buffers()
   File "/usr/share/screenlets/screenlets-pack-all/Clock/ClockScreenlet.py", line 256, in refresh_buffers
     self.redraw_foreground()
   File "/usr/share/screenlets/screenlets-pack-all/Clock/ClockScreenlet.py", line 269, in redraw_foreground
     self.theme.render(ctx_fore,'clock-face-shadow')
 AttributeError: 'NoneType' object has no attribute 'render'

Is it a bug because theme is not loaded yet, but screenlet already tries to use it? Could just check if theme is None before execution.

Papp Bence (sclegnrbs)
Changed in indiv-screenlets:
status: New → Confirmed
importance: Undecided → Medium
Julien Lavergne (gilir)
Changed in indiv-screenlets (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Märt Põder (boamaod)
Changed in indiv-screenlets:
status: Confirmed → Fix Committed
Julien Lavergne (gilir)
Changed in indiv-screenlets (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indiv-screenlets - 0.0.1~bzr838+repack-0ubuntu2

---------------
indiv-screenlets (0.0.1~bzr838+repack-0ubuntu2) natty; urgency=low

  * debian/patches/90-clock-theme-rendering.patch
   - From usptream (rev 899), fix crash when loading the theme (LP: #717987)
  * debian/rules:
   - Remove use of simple-patch.
 -- Julien Lavergne <email address hidden> Tue, 26 Apr 2011 00:51:47 +0200

Changed in indiv-screenlets (Ubuntu):
status: In Progress → Fix Released
Märt Põder (boamaod)
Changed in indiv-screenlets:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers