Transfer indicator needs internationalization

Bug #1348825 reported by David Planella on 2014-07-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Transfer Indicator
Fix Released
High
Unassigned
Ubuntu Translations
High
Unassigned
indicator-transfer (Ubuntu)
High
Sebastien Bacher

Bug Description

As with the rest of indicators, the transfer indicator needs to mark all its visible messages for translations and generate a .pot file. This needs to happen with enough time before RTM for translators to be able to do their work and for the translations to land.

Related branches

David Planella (dpm) on 2014-07-25
tags: added: avengers touch
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
David Planella (dpm) on 2014-07-29
tags: added: rtm14
Víctor R. Ruiz (vrruiz) on 2014-08-08
tags: added: qa-daily-testing
Víctor R. Ruiz (vrruiz) on 2014-08-25
Changed in indicator-transfer:
status: New → Confirmed
importance: Undecided → High
Ugo Riboni (uriboni) on 2014-09-02
Changed in indicator-transfer (Ubuntu):
status: New → Confirmed
Thomas Strehl (strehl-t) on 2014-09-04
tags: added: touch-2014-09-25
Sebastien Bacher (seb128) wrote :

One of the things dh_translations checks for, to know if a project is using intltool, is the presence of a po/POTFILES.in, adding one leads to have a template correctly generated during the package build. I'm adding a merge proposal doing that

Changed in indicator-transfer (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Sebastien Bacher (seb128)
Víctor R. Ruiz (vrruiz) wrote :

The .pot file must also be updated. Adding a merge proposal.

Ted Gould (ted) on 2014-09-05
Changed in indicator-transfer:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-transfer - 0.1+14.10.20140905-0ubuntu1

---------------
indicator-transfer (0.1+14.10.20140905-0ubuntu1) utopic; urgency=low

  [ Sebastien Bacher ]
  * Tweak translations setup to have a template generated (LP: #1348825)
 -- Ubuntu daily release <email address hidden> Fri, 05 Sep 2014 15:39:57 +0000

Changed in indicator-transfer (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

@Victor, why do you need to update the pot? The translations can be done on https://translations.launchpad.net/ubuntu/utopic/+source/indicator-transfer

Víctor R. Ruiz (vrruiz) wrote :

Sebastien: While marking strings for localization in some projects, I was also requested to update the .pot file. I understood that translations.launchpad.net grabbed the pot file from the repo.

Sebastien Bacher (seb128) wrote :

Victor, some projects do their translation in trunk, some use the ubuntu translations

Martin Pitt (pitti) wrote :

Right, when projects use Launchpad to do upstream translations the .pot needs to live in bzr trunk to get imported. But most Ubuntu packages only build the POT during package build and thus get imported into Launchpad as *ubuntu package* (not upstream project) translations.

The langpacks that we build are always built from Ubuntu package translations. They usually sync with upstream's (called "message sharing").

The slight advantage of also translating strings in the upstream project is that LP can (and usually is) be configured to directly commit them to trunk, and thus the turnaround between doing translations and getting langpack updates from them is just minutes. With Ubuntu translations you need to release/upload the project first and wait for a new LP export of Ubuntu translations. (langpack-o-matic has the script "merge-touch-upstream-translations" for that, which is a hack intended to speed up translations and the move to langpacks, but isn't intended to be a long-term thing).

So in summary, it's fine to do like the indicators and translate in Ubuntu only as long as there is an up to date POT being built during package build.

Adolfo Jayme (fitojb) on 2014-09-14
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers