i-sound slider on unmute resets volume

Bug #921065 reported by Conor Curran on 2012-01-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Indicator Display Objects
Fix Released
Medium
Charles Kerr
The Sound Menu
Fix Released
Medium
Charles Kerr

Bug Description

- Amplify volume over 100% using sound settings
- mute/unmute using keyboard
- volume resets to 100% and the over amplifed level from before

Related branches

Conor Curran (cjcurran) on 2012-01-24
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
status: New → Triaged
importance: Undecided → Medium
milestone: none → 0.8.1.0
Gord Allott (gordallott) on 2012-01-24
Changed in indicator-sound:
status: Triaged → Confirmed
Conor Curran (cjcurran) on 2012-02-13
Changed in indicator-sound:
milestone: 0.8.1.0 → 0.8.2.0
Conor Curran (cjcurran) on 2012-02-14
Changed in indicator-sound:
status: Confirmed → Triaged
status: Triaged → In Progress
Conor Curran (cjcurran) on 2012-02-22
Changed in indicator-sound:
milestone: 0.8.2.0 → 0.8.3.0
Conor Curran (cjcurran) wrote :

This happens because one of the feature requests around the slider is allow the user to click on either icon on either end to maximise or minimize the volume.
The only way i-sound then listens for this event is to subscribe to the 'value-changed' callback which when it is received will set the PA volume according to the slider position.
Because obviously the value-changed signal gets fired every time the slider moves due to user interaction or otherwise I need to filter the events to only listen to what i think are relevant (mouse click on ido icon events).

That triggers this bug. The slider at 100 and it unmuted is enough for my filtering to decide it try to set the volume to maximum.

Ideally I would like a special IDO signal for the mouse/icon click events. This would remove the need to subscribe to the value-changed signal resolving this bug.

Waiting on some feedback from Charles re the IDO signal...

Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
milestone: 0.8.3.0 → none
Olli Ries (ories) on 2012-03-06
Changed in indicator-sound:
status: In Progress → Incomplete
status: Incomplete → Opinion
status: Opinion → Incomplete
assignee: Conor Curran (cjcurran) → charles (charlesk)
Charles Kerr (charlesk) on 2012-03-09
Changed in indicator-sound:
status: Incomplete → In Progress
Charles Kerr (charlesk) on 2012-03-10
Changed in ido:
status: New → In Progress
assignee: nobody → charles (charlesk)
Charles Kerr (charlesk) on 2012-03-12
Changed in ido:
status: In Progress → Fix Committed
Charles Kerr (charlesk) on 2012-03-13
Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
milestone: none → 0.8.4.0
Changed in ido:
milestone: none → 0.3.3
Charles Kerr (charlesk) on 2012-03-14
Changed in ido:
importance: Undecided → Medium
Conor Curran (cjcurran) on 2012-03-16
Changed in ido:
status: Fix Committed → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers