[ffe] No easy way to turn the sound menu on/off

Reported by Matthew Paul Thomas on 2011-08-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Sound Menu
High
Lars Uebernickel
indicator-sound (Ubuntu)
Undecided
Unassigned
unity-control-center (Ubuntu)
Medium
Unassigned

Bug Description

indicator-sound 0.7.6-0ubuntu1, Ubuntu Ocelot

1. Try to work out how to hide the sound menu.

What happens: There's no obvious way to do it (short of uninstalling the package).

What should happen: "At the bottom left corner of the System Settings “Sound” panel should be a checkbox, “Show sound volume in the menu bar”. It should be checked by default for a new user account. Whenever it is checked, the sound menu should be present in the menu bar." <https://wiki.ubuntu.com/SoundMenu#presence>

[Reported by "Eustace" in <http://www.omgubuntu.co.uk/2011/08/power-cog-icon-oneiric/#comment-291049247>.]

description: updated
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2011-10-21
Changed in indicator-sound:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
status: Confirmed → Triaged
Changed in indicator-sound:
importance: Medium → High
description: updated
Charles Kerr (charlesk) on 2012-01-19
Changed in indicator-sound (Ubuntu):
assignee: nobody → charles (charlesk)
status: Confirmed → In Progress
Conor Curran (cjcurran) on 2012-01-24
Changed in indicator-sound:
status: Triaged → In Progress
assignee: Conor Curran (cjcurran) → charles (charlesk)
Conor Curran (cjcurran) on 2012-01-26
Changed in indicator-sound:
status: In Progress → Fix Committed
milestone: none → 0.8.1.0
Omer Akram (om26er) wrote :

How will we get it back once removed? Where will be the option for that?

Sebastien Bacher (seb128) wrote :

Charles, the merge done there could probably benefit from the tweaks you did from the bluetooth one, i.e drop the schemas checking, it's not required since the schemas is part of the application, also using g_settings_bind

Omer, if you read the wiki pointed the checkbox will be in the control center which will be available even if the indicator is not there

Conor Curran (cjcurran) on 2012-02-13
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.1.0-0ubuntu1

---------------
indicator-sound (0.8.1.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - No easy way to turn the sound menu on/off (lp: #829648)
    - Avoid spawning notification daemon at startup (lp: #912150)
    - Creation of album-art-cache folder (lp: #799383)
    - schema id & path are inconsistent with other indicators (lp: #914377)
  * debian/patches/correct_ldflags_use.patch:
    - typo fix in ldflags use
 -- Sebastien Bacher <email address hidden> Tue, 14 Feb 2012 19:46:41 +0100

Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
Christian Giordano (nuthinking) wrote :

How often is the case someone doesn't need the sound menu? What are the reasons behind this need?

"Try to work out how to hide the sound menu" is not a problem.

If the problem is "too many indicators visible", different other options can be taken and we have already solutions for it (see group indicators). Our sound menu is such a powerful feature which should probably be kept always visible.

Matthew Paul Thomas (mpt) wrote :

Nobody knows how often anyone does anything with Ubuntu, so it would be unreasonable to cite that as a reason not to implement this particular setting.

Use cases include:
* A PC at an Internet cafe, which therefore has no speakers.
* A point-of-sale terminal where the only sound is a beep, so it's not helpful to change volume frequently (or at all).
* My brother-in-law who has an old Mac in the garage solely for playing music, so the only volume control he needs is the one in the music player itself.

I wrote "1. Try to work out how to hide the sound menu" not as a problem, but as the step to reproduce the bug.

The sound menu is *already* a "group indicator", so hand-waving "group indicators" does not solve anything. If you have a specific alternative suggestion, then present it. But if it's inconsistent with the method of turning off the clock menu and the battery menu, then that will be a strike against it.

Charles Kerr (charlesk) on 2012-03-16
Changed in indicator-sound (Ubuntu):
assignee: Charles Kerr (charlesk) → nobody
affects: gnome-control-center (Ubuntu) → unity-control-center (Ubuntu)
Lars Uebernickel (larsu) on 2014-03-03
Changed in indicator-sound:
status: Fix Released → In Progress
assignee: Charles Kerr (charlesk) → Lars Uebernickel (larsu)
Changed in indicator-sound (Ubuntu):
status: Fix Released → In Progress
Sebastien Bacher (seb128) wrote :

We have similar controls for battery/bluetooth/datetime, asking for a ffe for sound so we have consistency accross the indicators for the LTS (that's a small code change)

summary: - No easy way to turn the sound menu on/off
+ [ffe] No easy way to turn the sound menu on/off
Iain Lane (laney) wrote :

Ok, this seems small and not likely to cause problems - please get it uploaded asap.

Changed in unity-control-center (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+14.04.20140305-0ubuntu1

---------------
indicator-sound (12.10.2+14.04.20140305-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Honor com.canonical.indicator.sound visible (LP: #829648)
 -- Ubuntu daily release <email address hidden> Wed, 05 Mar 2014 08:44:14 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 14.04.3+14.04.20140305.1-0ubuntu1

---------------
unity-control-center (14.04.3+14.04.20140305.1-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Add "Show sound volume in the menu bar" check box (LP: #829648)
 -- Ubuntu daily release <email address hidden> Wed, 05 Mar 2014 12:48:43 +0000

Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released
Charles Kerr (charlesk) on 2014-03-05
Changed in indicator-sound:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints